Worst. Bug. Ever. (Not Saving)

Okay, after losing an afternoon’s writing - TWICE - I’m logging in to research this nightmare of Scrivener not saving your work. I’m not sure if I feel worse, or better, that others have experienced this. I’m posting to make three elephant-in-the-room points:

  1. This is actually the worst bug imaginable. Crashes, formatting problems, interface things - all of its nothing. But this program is stealing writers’ work. It’s pretty much literally the worst thing that can happen. I mean, just for example, yesterday I was just struggling with this one chapter, trying get across my characters’ terrible existential confliction and tragic backstory… at the right pace… and in dialogue… and I finally started getting some flow, and so I stuck with it, and wrote right up to the end of the scene, by the end of my work day. Perfect. Closed it, opened it back up to check something… and poof, gone. After hunting frantically through back-ups and alternate project versions, I figured the only thing to do was to try and rewrite it on the spot, while it was still fresh. Ground it out - wasn’t as good as the original, because I was tired and angry and wanted to go home, but I got it down… closed it… poof gone. I cried this time. A compound word beginning with M was what occurred to me to describe the makers of Scrivener for Windows.

  2. Can any of us afford to use this product while this is happening? They think it might be fixed in 023? But couldn’t reproduce it? Should we be pouring our souls out, into their void?

  3. Assuming this doesn’t cause most of us to abandon the product forever . . . can we please have an announcement e-mail list for beta users, please? I could have been saved all of this, completely. When you realized your product was a menace, you could have told people. You’re like the Mayor in Jaws.

Thanks.

Probably, others of us can imagine how you must be feeling, to lose text.

For the time being, the safe solution is to compile to RTF to make a copy of your entire text. Or use another word processor until this unfortunate problem is fully resolved.

I think there are very many of us who don’t see this issue happen, on 023. But still, it is a very good idea to do the compile to RTF, which takes only seconds on top of any other normal saving or backup that you do.

Regards,
Clive

Fair enough. Thanks for the tip. (Wish I’d known you yesterday.)

And, I suppose, as my best friend used to say about problems with free software: “That’s the price you pay… for paying no price.”

It’s definitely painful and very regrettable that you lost so much work, but you have to remember that this isn’t ‘free software’, it’s beta software. There is a world of difference here. It means the program still a work in progress, and while Lee and others have made huge efforts to prevent data loss such as this, the risk in beta software will always be there. Anyone who cannot risk such a loss would probably be best to wait until the released version is out. As good as the software is, it seems hard to wait, but it’s the only for sure safe route.

WOW! Pretty harsh. I’m guessing you’ve never beta tested before, right?

Losses of work happen anytime you test ANY software. Nobody likes it, but we were all warned that we’re walking in unexplored territory. Normal procedure is to take something you already have in Word, or Final Draft, or a graphics program, etc and work the software through its paces.

Every programmer I know is a perfectionist who works intense hours to give us cool programs–from basic OS, Photoshop or even Word, and now Scrivener.

Stay cool.

Yeah, I’m a programmer, too. (And likely will be forever at this rate, but never mind that . . .)

And of course you’re right that it’s beta software and there are no guarantees. I assume the risk myself.

All that said, this was particularly horrible. It’s one thing to have to be responsible for frequently backing up your work, in case of crashes or corruption. It’s another totally when saving doesn’t actually save (but only appears to). In a program made for writers. When your work just magically reverts to several hours ago. Including if you “saved” a back-up version.

It’s uniquely bad. You literally couldn’t have designed something worse.

Plus how hard can it be? Even Microsoft products, even Notepad, saves when you press control-S.

Plus the production product is supposed to be out month after next. And the developers say they can’t reproduce the issue and have no idea if it’s fixed. And it came to light, and they kept on letting people burn work.

Fair or not, this is likely to dog them. “Yeah, we make these fantastic planes. Though, on occasion, they’ve been known to fall out of the sky. Probably not. We think they’re fixed. Just make sure and pack a parachute and you’ll be fine.”

On the other hand, there is (now) a known work-around: Compiling to RTF.

So I suppose that’s more or less sorted, at least as far as losing work goes.

Though I will be spending a lot more time on my Mac going forward . . .

Actually, I’ve never been on a plane that doesn’t have floatation vests, oxygen masks and life rafts. I do understand your frustration though. From my own perspective, I have realised that I’m not really a “beta” person.

My original thought was “great, I can use this as a free trial to see if I want to buy SfW when it’s formally released”, but that was really the wrong approach for me to take. The point of using a beta is not to try-before-you-buy. It’s to stress test the software as a favour to the developer. So rather than a ‘beta software has no guarantees’ philosophy, perhaps a ‘beta software is not about being promised something, but having an opportunity to help (and influence) the developer’ approach is more appropriate. So from my perspective, I don’t really have the time to be a proper beta user and just dip in now and again on the latest releases and report stuff I find that surprises me.

Luckily there are lots of people out there who are more patient than I am who, have invested a lot of time helping the hardworking L&L team produce something that is going to be quite special. I look forward to paying for it.

Just to give some perspective here, there have been far worse bugs in released products that are beyong anything we could imagine here.

10 Worst Bugs of All Time.
wired.com/software/coolapps/ … 5/11/69355

The fact that they can’t reproduce the issue just means it isn’t an obvious issue. Don’t forget, this is a small operation and they are working overtime to bring us the final release as quickly as possible. While the schedule may have been a little rushed, they also have had to put up with us begging and pleading for the software to be released by impatient people like me!

As far as abandoning the product, anyone who would judge a beta so absolutely, with all of the constant feedback, updates and attention we have received on this beta, has no business even trying out beta software. There have been few betas I have been a part of where we have recieved such support from the developers. There is a free trial for the finished Mac version, and I’m sure the same will be true of the Windows version when it is released. This is what people who are unwilling to risk losing any work should wait for.

Treating a beta as a trial is never a good idea. Again, it sucks that people have lost work. But that’s a risk we all knowingly accepted by using the beta for anything production oriented. I stopped using the beta since 0.22 for anything ‘production’ and am waiting until we have a new beta that has been tested long enough to be sure it’s saving okay before I resume using it for serious work. I don’t like having to do that. But it’s the result of the decision I made to try something new and interesting before it was completed because I was too impatient to wait for the released version. And though there’s been a few bumps, I haven’t regretted that decision yet.

I understand your frustration and am sorry to hear that you think we’re a bunch of meatloaves. Obviously our aim is to create great software, and if Scrivener failed to save, that is very, very serious and we sincerely apologise for your loss of work (were it not a beta we would of course give you a refund). Scrivener is tested on several machines before it gets put into public beta, so we are gutted that this got through at all. However, could you please clarify - you make lots of sceptical comments about 023, but, unless I missed it, you never actually state whether or not you have actually updated to, and are using, 023.

Are you saying that Scrivener 023 failed to save? We thought 023 had fixed this issue so if so this is the first we have heard of it - the saving issue was, to the best of my knowledge, an issue with 022 only. And fixing this wasn’t pure guesswork as you seem to imply - Lee couldn’t reproduce the saving problem on any of his machines but after lots of hard work found a piece of code that seemed to be the culprit. If you are a programmer then you will know that there are nasty bugs that users experience that just cannot be reproduced on test machines no matter how hard you try, because there are a billion factors and reproduction relies on finding one of them.

So, I’d be grateful if you could let us know if this problem occurred on 022 or 023.

Regards,
Larry Vaughn

P.S. We announce new betas at the top of the forums. Beta testers are recommended to check here regularly for updates.

I realize not everyone has beta tested software before. (I can tell you horror stories, but I don’t know if an NDA is still binding in the one case.) But here’s a few things to keep in mind.

1.) the problem can’t be fixed, if it can’t be reproduced. That means:
2.) Provide a list of things (bullet points are best) to reproduce it. Include everything you do. It may be a quirk of how you’re using the program that’s causing it to crash or bug.
3.) Include your computer hardware and OS (including any service packs.)

And as a linux user, the dig against free software was totally unnecessary.

I’m putting a reward out on this bug as we want to squash it fast:

https://forum.literatureandlatte.com/t/urgent-reward-for-help-with-the-non-saving-bug/12472/1

Thanks,
Keith

It might be helpful to know if the people experiencing the not saving bug have been uninstalling the old versions or installing on top. I had happened to uninstall when I did the .22 upgrade as I knew it would reset everything from Lee’s post and I wanted to keep things clean. I have not been able to repro the issue, though I can’t say if that had anything to do with it or not. But the more information everyone gives, maybe a pattern will become clear.

That’s a good point, and I’ve added it to my bounty instructions.
Thanks,
Keith

Same here…I did a clean reinstall (both versions) and can’t reproduce.

I’ve not experienced this. Mine is saving fine… I’m on version… 022 for windows…

SAVE MANUALLY as often as you think of it. Compile and save the RTF…

I’m pushing the research capabilities to their limit, fyi… and save for a few random crashes, not seeing the fail to save …

Good luck! and remember, writing is rewriting…

Ashley
@wiremamma on Twitter

Here’s another thing that doesn’t create the bug:

I copied my wine directory to a different one and installed version 022. (So as not to mess up my working Scrivener installation.)

I installed 023 over it without uninstalling, and it’s saving normally. All my preferences and things were reset upon installation, as it should’ve been from a clean install. Unless it’s not a dirty enough installation? My wine registry doesn’t have nearly the cruft that a normal windows user has.

Before I did a clean install (uninstalling and removing earlier versions), I had never experienced losing any data except with some template issues (which is being worked on and certainly isn’t a big deal since I copy via Windows Explorer).

With .23 clean install, still no problems. Taste Great, Less Filling. After reading this thread, I realized I am using the beta in production mode–probably because of almost no problems at all using the software, which lures me into a “safe mode” of operation under false pretenses (my own). Having said that, if I lost my data tomorrow, while I would be nuts, I would have no one to blame but myself.

I’m not a developer and have used very few beta mode software, but I know, and I mean, I really know, that using beta is risky business…kind of like buying a used car…as is, no guarantees.

I am truly grateful Scrivener’s is being developed for Windows. Let me say that again…grateful. Thank you so much to all those busting their ass to make this a fully operational death star…um, writing program. This program doesn’t kind of suit my needs…it suits my needs nearly perfectly.

Keep up the great work. And if someone gets a bug, don’t kill it, report it. :smiley:

mrfuches, I just read further doings on this thread, and notice you’ve been quite good about it, which I’m certain is appreciated other places besides here.

Since you have this problem, could you do the complete de-install, and then fresh install of 023 as I’ve mentioned in comment to Keith’s bounty post?

It might really show up something; that some important and potentially mis-matching Scrivener parts were not being replaced properly by the installer, and thus actually causing this problem. That’s beginning to look like a possibility for the issues, based on other posts.

If you can, I would:

  1. of course copy your present Scrivener work projects and save the copies elsewhere, just as an over-precaution, but we are dealing as you best know with trouble here.

  2. de-install Scrivener from the Windows control panel, whatever yours is called where you find a listing of installed programs and are given a choice to deinstall.

  3. After the deinstallation completed, go to c:\Program Files, and find the Scrivener directory. Be sure that’s what you have selected, and then delete it by using the Delete key, or pulling it to the Recycle Bin. Answer any prompts your computer makes appropriately, also checking if possible to be sure you’re deleting the right thing as we don’t want to have problems for your other installed programs.

  4. Now that Scrivener is completely deleted from your machine, you can make a fresh installation.

  5. Be sure you’ve downloaded the Beta 023 installer from the appropriate green button on literatureandlatte.com/scrivenerforwindows/. The Windows installer should be named Scrivener-023-installer.exe once it downlaods.

  6. Double-click your download and install Scrivener.

  7. Run a short test by creating a new Scrivener Project and writing a few things in it, then pausing a few seconds (2 sec timeout), and quitting Scrivener. Then re-open, and see if your writings are there.

  8. If successful, try a longer test with more writing in several segments; rinse and repeat on the closing-reopening-verifying.

  9. If it’s looking good, then I guess some extra writing on your prior problem project, being sure to do the compile-to-rtf step before quitting where the extra is something you want to save. Personally, I’d test with some inconsequential writing, just as in the new project test above, first.

Am sure you could figure this on your own, but hope step-by-step in such fashion useful.

Thanks on behalf of the community, I am sure.

Regards,
Clive

I just want to say that I also lost work in version .22 and feel the pain. BUT I knew what I was signing up for when I started using a beta, so I’m not angry. The lost work was my own fault because I didn’t do a compile. I’d done that at the end of every session when I started using the program and had gotten complacent as I got comfortable.

It’s an unpleasant bug, but I’ll keep using the program through the beta and reporting bugs when I find them. You guys are doing a great job.