Wrong font in compiled heading

(Scrivener 3) My very simple project has two files, heading and text. The text is a section, and the heading is a section head (although some places say “ss heading”). I am compiling using Manuscript (Times).

The section is fine–I draft using Courier Prime, and it compiles into Times New Roman.

After having problems with the heading, I changed the draft font to Times New Roman. In the Compile window, its section type is “heading” and the appearance is “as is”. (I want my name & address in a block at the upper left, for example.) Now when I compile the project, the heading comes out in Courier Prime. (I remember fiddling with settings, but I don’t remember what I did.) I want the heading to be in Times New Roman, like the section. How do I do this?

Have you selected the font for the heading in Compile Format Designer > Page Settings > Header and Footer Text and chosen a Header Font? See image below.

1 Like

I don’t recall seeing this page. Unfortunately, I don’t see how to get to it. Unless I’m missing something, I can’t get there from Compile or Format.

Double-click the Compile Format you’re using in the left column of the Compile Overview window to open the Compile Format Designer window.

2 Likes

I am attaching 2 files–the heading before compiling and the first page of the document after compiling. I found the Compile Format Designer and created a new compile format, Ms_me, with all the correct settings–I think. The problem of the header file changing to Courier still exists.


Isn’t your header document compiled ‘As is’? So, just change the text to the appropriate font in the Editor, and it should compile unalterated.

That’s what I tried to show when I attached the screen shots. The editor has the yellow background, and its text is in Times New Roman. The white background has the compiled result (in Word). If you look closely at the white, you can see that “Victory,” from the header, is not in the same font as the first sentence. “Victory,” plus the name, address, and word count, is in Courier, and the first sentence is in Times New Roman. I’m still stumped.

Ah, it’s the other way around. :crazy_face:

First, remove the title from the header document, and place your document in the Binder in a folder called “Victory”.

Then check the Section Type of the Header document, it could be “Header” or something else.
You can find it in the Inspector with the middle tab “Custom Metadata” selected. If it’s Part, or Chapter or Scene, make it Section Type “Header” via the bottom option “Edit”.

Double-click the Compile Format you’re using in the left column (Copy and Edit if necessary). For the “Header” Section Layout that is coupled to your header document, determine the Formatting in the formatting editor halfway down the right-hand side of the window. So, click the text and change the settings in the Format Toolbar.

Now for the “Victory” title, select the Section Layout for “Chapter heading” (or similar) and set it to centered TNR with the right font-size. Make sure the Title Content type checkbox is NOT checked and the Text Content type checkbox IS checked.
Click OK to close the dialog to save the Compile Format.

In the Compile Overview window, using the “Assign Section Layouts…” button at the bottom of the middle column, check that the Section Layout for the heading is Assigned the “Header” Section Type and the Chapter Section Type is Assigned the “Chapter heading” (or similar) Section Layout.
Click OK to close the dialog.

Click Compile in the Compile Overview window.
Rinse and Repeat 'till your happy. :smiley:

Hope this helps

2 Likes