Zotero, academic writing and a great confusion

Hi everyone,
I’ve recently bought Scrivener 3. I’m fed up with word and its boring crashes. I’ve always wrote using zotero plugin in word (the only thing wonderful in word) .
Now, shifting from word to Scrivener I must solve problems connected to:

  • citations
  • bibliography
  • template (but I have to study more this item)

I installed bib(la)tex in zotero, created a .bib file. I’m struggling to understand pandoc sintax and I use marked2 for preview. For now I installed a pandoc scrivener applescript that I put as bibliography manager.

It work fine because when I press CMD+Y I can choose citation from Zotero. Pasting citations from Zotero is very simple.
In marked2 using this arguments:
-f markdown -t html5 --bibliography=/Users/Gallomac/Desktop/Pandoczotero/Bibliozotero.bib --csl /Users/Gallomac/Desktop/Pandoczotero/cell.csl -smart -s
I can see that a bibliography and citation are good

But…after?
What steps I had to do for creating documents (word, pdf and so on?).

I’m trying to learn pandoc syntax and I read a lot of things (the last one about a “pandomatic” method) but sincerely it is very hard for me to climb this cliffs with a manual of almost 900 pages.

Thank you in advance
2018-02-21_14-59-04.tiff (838 KB)

Hi Gabriele, you are 90% of the way there, if you have got Marked2 working with Pandoc. Indeed it is possible to save DOCX / HTML from Marked 2. But I prefer to do this automatically using Scrivener’s compile.

I’ve written instruction on my workflow to do this automatically in Scrivener 3, along with some tips. I do use pandocomatic, but this is not necessary, you can use Scrivener + pandoc directly (managing settings for multiple formats is more annoying, which is why I choose pandocomatic).

I’ve created a test Scrivener project which contains all the templates and a sample bib file and compiles to docx, latex and html automatically. Read Resources>Instructions on how to set this up, if you can get this working then you are 99% of the way! 8)

github.com/iandol/scrivomatic/b … .scriv.zip

HI nontroppo!
Thank you very much for your advice and, above all, for your great work! I have to study as soon as possible and I hope to understand all. In case of doubts I hope in your help again! :smiley:

Dear nontroppo,

I am not the user who started this thread, but because I tried to use the Workflow.scriv file you kindly made available to them here, I thought it would be more appropriate to post directly in this thread.

First of all, thank you very much for generously making that file available: I learned a lot from it! Unfortunately, however, I am having a problem with the post-processing step, and I was wondering whether you could be so kind to point me in the right direction.

I replaced the path you had for the scrivomatic.rb file in Workflow.scriv with the path to that file on my computer. To make sure the path was correct, I dragged and dropped the scrivomatic.rb file in the terminal window, and used in Workflow.scriv the file path that appeared in the terminal window:

When I compile your sample manuscript, Scrivener generates a perfect workflow.md file, but it’s unable to generate the other files (e.g., the docx file) because it seems to be unable to find the scrivomatic.rb file:

.

Would you have any idea what I am doing wrong?

Thank you for your consideration.

Best regards,
Enrico

Have you tried removing the backslash character? That looks like it is escaping a space character* – something that might not make sense where you are using it outside the Terminal app. (This could happen if Scriv preps these settings by applying escaping for you but without being cognizant of existing escaping.) Worth a try anyway.

The path shows the workflow_mmd folder to be at the top level of your user account. That would mean it is in your home folder. Is that correct?

-gr

  • If that is right, your user account name on this machine is ‘enricoscarpella 1’.

Dear gr,

Thank you for your kind reply. You’re right on all accounts: the name of my Home folder is “enricoscarpella 1”, and that’s where the “workflow_mmd” folder is located. But I should have been clearer in my post: I had already tried to remove the backslash, but in that case it seems Scrivener does not go beyond “enricoscarpella”, i.e. does not consider the “1” in the name of the Home folder, because when I try to compile I get the error message:

/bin/bash: /Users/enricoscarpella: is a directory

I have also tried using “enricoscarpella1” and “enricoscarpella_1”, but to no effect: I still get the same message as in my previous post. I am really at a loss… But again, thank you for your suggestion!

Best regards,
Enrico

Can you use the ~ convention to specify the path without need to include the User/accountname part?

gr

P.S. Maybe this is very old think, but to me the root of your problem is using a space in the account name on your machine in the first place. In fact, I didn’t even think that was possible!

Mac OS once allowed me to create my first account on my laptop which it later (much later) told me had an illegal short name. Can’t remember the details now, but my family name has long had a tradition of breaking databases, log-ins and so forth (it has a hyphen in the middle}. Many databases still cannot stretch to capitalising the initial letters of both elements of the name.

Anyway, I just recently changed the user account name on my laptop, and it was very easy. (Basically, you just create another admin account, use it to change the name of the original admin account, then delete the new account.) So a simple solution might just be to eliminate the space. Unless you have loads of scripts that refer to the name with the space …

You can now paste the scrivomatic script directly into the scrivener post processing panel (where you see the path: drop down), this should solve the path problems…

Dear rg,mbbntu and nontroppo,

Thank you for your suggestions.

  1. Unfortunately, rg, the “~” trick made no difference,… But I think you’re right: I think that space is tripping Scrivener off — though it does not bother other applications…
  2. You’re right, mbbntu: in retrospect, selecting that name for the account was not the smartest thing; changing it is definitely on the radar, but for many reasons I need to do it with someone from our IT department, and understandably it’s not very high priority for them, so I’ll have to wait my turn…
  3. Pasting the script, as opposed to the path to it, worked just perfectly!

Thank you again for your help!

Best regards,
Enrico