024 deb?

Thanks for the details – I think those are very helpful for anyone who is trying to use a .deb.
I really would like to dig into some of this, but time is short at the moment. I’m hoping I can test some of these things on a clean VM install.
I have spell check working on my Ubuntu 11.04 32-bit system, but I’ve also had this system running and continuously updated with lord knows what libraries since probably 2006. If something is necessary, it’s probably already there.
My laptops are running 11.04 64-bit, so I’ll check those as soon as I can. (At the moment, I’m using them to do some filesystem backups – looks like a different hard drive is dying, so…)

The ‘Scrivener’ versus ‘scrivener*’ thing was a bit of a surprise to me as well. I don’t know if it’s possible to do symbolic links via .deb files, but that might be one way to solve that.

I’ve only packaged one other application, so I’m still quite a newbie on that front. But since the Debian packaging system is one of the reasons I started using Debian (then Ubuntu) originally, I’m happily learning what I can (now that there is a need, as it were).

Can you point me to one of Randy’s templates so I can peek at that as well?

I’ve tried installing both Rob Hamm’s and J G Starsoupsky’s deb packages, and each time I’ve tried to create a new file Scrivener has shut down and this error message has appeared in the terminal:

/usr/share/LiteratureAndLatte/bin/Scrivener: symbol lookup error: /usr/share/LiteratureAndLatte/bin/Scrivener: undefined symbol: _ZN9QTextEdit25currentTableFormatChangedERK11QTextCursor

I’m running 10.04 LTS - the Lucid Lynx, if that’s any help.

(And, if it’s not already obvious, I’m not particularly clued up on command line level stuff)

Same thing here, but on a 32-bit 11.04. I tried to install with dpkg -i


Which .deb version are you seeing that error on? What was the exact command you typed?

Do you have any previous versions installed (wine or native version)? How are you launching the Scrivener?

Garpu, you realize that being snarky does not actually encourage people to learn OR make you look smart? Instead, it makes them discount you (and linux, thanks much) and makes you look like a jerk.

As a serious note, garpu’s actually right. It was almost as easy to install via tarball - because it’s already compiled. If you’re still having trouble with the deb file, give this a shot (I’m running Openbox over Ubuntu 10.04):

Download the file. File-roller uncompresses the tarball easily, the script here makes the libraries load properly, and I just posted instructions on creating a launcher


I tried installing it as a tar wotsit a while ago and never got that to work so deleted all the files that were zipped up in there. And then these 2 later versions. I uninstalled via the software centre before trying to install it the 3rd time. I launched it via the terminal.

. . . . . . . .

At this point it might be best to wait and try again with the June 30 update.

Thank you! Just installed the new release and so far it’s working fine!