024 deb?

Could someone point me to good instructions on how to do this myself? Thank you in advance!

I’ll try and put one up, not got direct access to the linux box. I put rough instructions up in the .23 deb post
http://literatureandlatte.com/forum/viewtopic.php?f=33&t=12833#p93991 here

Perhaps we need a wiki on creating the deb packages (unless there’s already one that I’ve missed)? That way we could aggregate the combined wisdom of our generous deb builders. I’d be happy to get involved – I have several Ubuntu boxes, though no Debian system at the moment.

You don’t need a deb. Untar it somewhere, then use /lib/ld-linux.so.2 to load the scrivener-specific libraries.

cs.virginia.edu/~dww4s/artic … linux.html

Sure, one does not literally need a .deb, but some people like them. So they can install when drunk and being attacked by thieves. Clickety-click, or at least a minimum of typing. This assumes someone does the work in setting up a .deb of course. In general, packages are useful for when you want to uninstall, as well (in a package agnostic fashion).

Here’s my attempt at a .deb package, based on the version and instructions by cwoac .

How is “rm -rf /usr/bin/LiteratureAndLatte” not uninstalling?

It’s not package/product agnostic, and it’s not necessarily a clean uninstall.
If you’re already using a VCS on your entire filesystem, this won’t be an issue. Etc, etc.
I’m glad it works well for you. Some people want rpms, debs, shell wrappers, or whatever assorted doo-dads they’re used to. Presumably they’ve more interesting things to worry about.

Right like not knowing basic linux system administration.

I made a deb for 2.4. It’s at robhamm.com/legacy/primary-categ … ux-24-beta

It installed just fine via the Ubuntu software center, and is working fine, as well. (Except for spellcheck on my 64-bit system. That is likely an error on my part, though.)

Hey! I resemble that remark! :smiley:

(Seriously, though–With Ubuntu’s move to the clunky Unity interface that makes it take four or five clicks and maybe some typing what used to take a single click, the idea of rolling my own distro is sounding better and better. Yeah, I know I can opt to use the standard Gnome interface with AWN, DockbarX, Mintmenu, and mostly get rid of panels–like my current setup–but just that Canonical thought Unity was a good idea makes me question the future of the distro.)

omgubuntu.co.uk/2011/05/gnom … aris-unix/

Sounds like Ubuntu may have to switch desktop managers in the future, anyway.


Ubuntu Sorftware Center was unable to install your package. I then tried sudo dpkg -i scrivener-beta_2.4_all.deb , and here is the output:

Any thoughts?


hi i also got the similar error:
error in Version string ‘beta-2.4’: version number does not start with digit

Platform was 64bit Ubuntu 11.04.

You could try the version I posted as well – worked for me with dpkg -i anyway, on 10.10 and 11.04.

I installed on 11.04 64-bit with

 sudo dpkg -i --foreign-architecture i386 filename.deb 

@JG Starsoupsky

For some reason, downloading your package from megaupload.com/ is not working. It might be my connection and not them, will try again later.

Hm. Very strange. It installed for me without a hitch. I’m not a developer by any means, but when I have time later tonight I’ll dig into it and see what I can do. And wait… I didn’t realize there was already a 2.4 deb posted. Where is it?

The .deb I made (based off of cwoac’s template) was posted a little earlier in the thread with a megaupload link.

Anyone is welcome to try a direct download as well now (scrivener_0.2.4_i386.deb) :
handsomeplanet.com/wp-conten … 4_i386.deb .

JG Starsoupsky thx a lot installation went just fine.

Good to hear. Out of curiosity, what platform are you running (Debian/'buntu version, and 32 or 64-bit)?

@JG Starsoupsky–
I uninstalled the package I put together and installed yours using

dpkg -i --force-architecture scrivener_0.2.4_i386.deb

(sudo dpkg -i --foreign-architecture i386 scrivener_0.2.4_i386.deb didn’t work for me–Just threw a bunch of errors.)

Working great so far, and thanks! The two packages, once started, seem to run about the same.

A couple of things caught me by surprise, though–The command to launch via terminal is Scrivener, not scrivener (or scrivener-beta), as it was in earlier iterations, and the launch icon is created in the “other” section (as opposed to “office”), and is initially hidden until you go into “edit menu” and check the box. All that needs done to have the launcher go to the “office” section is to–in the Control file–list the section as “editors.” No idea why it didn’t show up at all by default, though.

As for the package I built, I’ve been basing mine on the ones Randy was building, and while they install and uninstall without a hitch using Ubuntu’s software center, they no longer show the beta expiration notice. And spell-check still doesn’t work in either your package or mine on my system. Is this a function of the 32 vs. 64 bit architecture having library disagreements? And if so, any ideas how to change that to either make one universal build or split off into separate 32 and 64 bit branches? I don’t know what to change there.

I’m on Ubuntu 10.10 Maverick 64-bit, by the way, and I have the 32-bit spellcheck libraries installed.