029 odd experience during installation

Tonight, I tried to open 026 but it would not pull up. No expiration notice, nothing.

So I uninstalled, and was about to reinstall, when I decided to see if there was an update, and that perhaps the program had expired even though it did not give a notice.

I downloaded the 029 update, then told the installer to open the program. But nothing opened. I restarted the computer, clicked on the shortcut, but got a computer notice that it could not find the program, to browse for it.

I opened the main Scrivener folder and saw several files and folder, including the uninstall.exe, but NO Scrivener.exe.

I uninstalled the program, restarted and re-installed. It seems to be fine now.


  1. Had 026 expired? (might be good if there was a popup notice to that effect)
    If it had NOT expired what do you think caused the initial problem?

  2. Why do you think the first installation of 029 was faulty? Should I have restated between the uninstallation of 026 and the installation of 029–could that have caused the problem?


Hi Marta,

The 026 beta shouldn’t have expired until August 16th (it is good through the 15th) and it should give a notice to that effect, so I’m not sure what was going on there that caused the program not to launch. If you were using a shortcut, that might’ve gotten corrupted somehow, or if you had a crash the last time you ran Scrivener that might have caused a problem, though the only instance I know of where that has happened, an error message does pop up when you try to launch Scrivener.

Likewise I don’t have a very good answer for the initial install of 029 not working. It could be due to the uninstall of 026 not going cleanly, although it’s still odd as it should be able to install directly over the earlier install and clean up by itself. Did you run the installer as admin or as a standard user? If 026 was installed as admin and 029 was not, that might cause some problems in attempting to overwrite the earlier file, but if that’s the case it seems unlikely you’d have them both in the same location. Did the initial 029 installation seem to go properly all the way through “Setup Complete”?

What OS version are you running? That’s the other thing that might play into this.

Scrivener had been working perfectly without crashes.
I didn’t think about the shortcut having gotten corrupt,as it’s never happened before, but perhaps that’s what the problem was. I did not think of going the the folder and clicking the exe. I figured uninstall/reinstall, then thought it might have expired and checked your site.

my computer is set up to install without asking or having to log in to administrator privileges.
029 installation went smoothly, the set up seemed to complete as far as I could tell-- it asked if I wanted to view the read me file and/or launch Scrivener. I unticked the “view file” box, but left the “launch scrivener” box checked. When the program did not launch or give me any notice, I opened program files> Scrivener, searched the folder, saw several sub-folder and files, including the uninstall.exe, but NO Scrivener.exe.

I uninstalled 029, restarted and re-installed 029.

The only thing different that I can think of is I usually restart between uninstalling and reinstalling and, this time (between 026 and 029), I was perhaps too much in a hurry to write some thoughts into one of my projects, and didn’t bother with the restart.

Why 026 did not pull up is weird but like you said, perhaps the shortcut had gone screwy

I’m on WINXP Service pack 3, all the latest upgrades, plenty of RAM and HD.

Hm, the one thing I’m thinking from this is that it’s possible you did run the 026 installer as admin but when you uninstalled you just ran that regularly–this really should’ve given you a couple error messages letting you know that there were a few things that couldn’t be cleaned up due to you not having the necessary privileges, but overall the uninstall would’ve worked, it would’ve just left a couple files such as you found later. If you installed 029 to another location–for instance, if you’re not installing from an admin account or running the installer as admin, it will default the install to your Documents directory–you might’ve gone to the old 026 location in Program Files and seen the files that weren’t uninstalled, but this would’ve been separate from the new 029 files. Scrivener not starting properly after the installation is a separate bug that I’ve seen and a few other users have reported, so that might’ve happened even if the 029 installation did go correctly and the .exe file really was there (in the other location).

All of that of course is just speculation; if you’re using an administrator account, then the standard/admin issues wouldn’t apply, or if you always did the installation to the same location in Program Files it likewise shouldn’t have been a problem. In any case, I’m glad you’ve got everything up and running properly now, and I’m sorry you had these difficulties!

Hi Jennifer
I install all my programs to C:/Program Files/
I did a search and I found these references to Scrivener
(all my projects are on a different drive, that’s why they don’t show up)

BTW: Regarding the Scrivener folder listed under Documents and Settings>Application Data
I imagine that’s where most people put their projects. Since I use a different drive, can I delete that folder or will that screw up the registry? (that main folder only has 2 empty sub-folders-- Layouts and Project Templates, and 2 files – userlock.id and wordlists.ini )


I checked the registry to see if there were references to a different path other than
C:/Program Files/Scrivener
Everything is fine. Only other path references were to the D drive where I have my projects



Ah well, it was a long shot. Good to know at least that it wasn’t that.

The Scrivener folder in Application Data is used by the program for storing user-created layouts, templates, etc. and shouldn’t be deleted. It’s unrelated to where you store your projects–in fact, I sincerely doubt most users will store projects here, as the Application Data directory is typically used, as it says, for applications to write their own extra settings files, etc. The default for creating projets is just the user’s My Documents folder, though of course you can store them wherever you like. Scrivener will only know to look in your Application Data folder that it created for the other settings files (you don’t get an option, when you create them, for where to save them), so that’s best left alone. If you need to copy any files out of there, you can usually do so from the interface with an “Export” sort of option, or you can copy them directly from the folder using Windows Explorer.

The “wordlists.ini” file is your personal word lists (words you’ve added to the dictionary, etc.), so for instance you might want to copy that to the same location on another computer where you’ve installed Scrivener so that you don’t have to make the list all over again.

Very helpful info.
thanks Jennifer,