035 Cannot type [ in editor (left square bracket)

I have tried 3 different keyboards - it is not possible to type [ in the Scrivener editor.
The only way to get it there is by copy-and-paste from an external editor.

Even keyboard shortcuts with AutoHotKey do not deliver. For instance, this AHK macro:
F8:: Send, [test]
results in test] in Scrivener.

The right square bracket is a bit easier: at least an AHK macro works for it.

This is probably due to the fact that I am German and type on a German keyboard.
But all other Windows software (Wordpad, Notepad++, MS Word…) accepts AltGr-8 or Ctrl-Alt-8 as [ and AltGr-9 or Ctrl-Alt-9 as ] on German keyboards. Except Scrivener.

I hope this can be fixed.

Addendum:
The left square bracket cannot even be inserted from the Clipboard with AHK:
F8::
Clipboard = [
Send, %Clipboard%
return

  • does not work either. But I finally got it solved with this:

F8::
Clipboard = [
Send, ^v
return

Edited because I have had caffeine and reread the post and caught the critical part I missed earlier about the German keyboard. I suspect it’s an issue with Scrivener not taking the AltGr key input properly; we had some earlier issues with this which were fixed but there might be something that slipped through causing the problem here. I’ll make sure to pass this on to Lee.

The left square bracket works on my netbook (english UK keyboard setting).

Thanks, MM and Camy.
I can confirm it is the keyboard setting.
Changing my keyboard language to EN I can type [ into Scrivener by tapping the appropriate keys where they would be on a US keyboard (tested on Win7).

I am fine for now with my AHK macro, but it might cause difficulties for other users in other countries.

First off, many thanks for the release of 1.0, great to finally have it! However, I am still experiencing the issue described in this thread, hence this push.

It is still impossible to type a ‘{’ or a ‘[’ in the Scrivener editor using a German keyboard (AltGr+7 and AltGr+8 respectively). Tested on Win 7 Pro 64bit and Win 7 Home 32bit. Thanks!

For anyone wondering, the UK keyboard equivalent of this problem is ‘€’ (the Euro currency symbol) from pressing + 4.

This is also not recognised in the editor. It can, however be used when inputting text into an index card on the corkboard, or in the index card in the Inspector pane. A temporary workround for owuld be to type one there and then cut and paste it into the editor.

No fix as yet but I just wanted to assure you that this is on the list for a 1.x update; we haven’t forgotten!

For the record: I’ve got the same problem as tentacles20 (though it did not occur in any of the beta versions I tested). My Scrivener 1.0 is running on a Win XP Home Edition machine.
This is quite an irritating one…

The 1.0.2 update is available and hopefully fixes this issue. You can use Help > Check for Updates to download and install the update.

I can confirm that it works for me in the following areas:

  • Corkboard index cards
  • Index card titles and Index card main body in the inspector pane
  • Document Notes in the inspector pane
  • Outliner
  • Binder
  • Editor

There is intimitant success in:

  • The Keyword HUD
  • The search box just above the inspector pane

If you select these just after having selected the Editor pane, then they don’t work. But if you select these two from somewhere else - eg the binder or the inspector pane - then it works fine.

Weird!

EDITED TO SAY:
Possibly not relevant to this issue, but…
Windows XP + SP3
WinScriv v1.0.2
Installed w/out admin

Just a bump to make sure that this has been picked up…

Yes, it has been. :slight_smile: