1.2.5 Scrivener for Linux RELEASED

Hi All,

The Linux build for Scrivener is finally ready.

You can find the archive package and the Debian installer here:

literatureandlatte.com/scriv … ner.tar.gz
literatureandlatte.com/scriv … 5-beta.deb

Tested on clean 10.10 32 bit Ubuntu.

Expires - 30th June 2013 – (Scrivener 1.2.5)

P.S. Expect another update around Nov/Dec 2012 regardless with more features.

Woohoo! Doesn’t seem to be any problems so far with it. Is this the one with the full MMD integration? If memory serves, the old Linux version didn’t have the MMD support that the windows one did.

This is unbelievable!
Just on question… any chance to have a PPA for Ubuntu?

Thank you very much!

I might be wrong, but I don’t think this can be a ppa because launchpad requires projects to be FOSS based development.

Very cool to see this released, though!

I am a happy writer, right now. I love this program, and thanks to a sales consultant, by the name of David, you guys have a loyal customer of this program. Looking forward to future updates.

DOA on my 64-bit system. See this thread:


Works on my Eee PC running Ubuntu 12.04. Doesn’t show up in Ubuntu Software Center though, even though it installed it.

Thank you, Lee!

Thank you. Works smoothly on 32bit Linux Mint 12 (and Eee PC). Installation took all 30 seconds :smiley:

However, the font rendering is a bit weird (different from before, is there a way to change it? Or well, I’ll get used to it I suppose) and I lost my Finnish spellcheking. Nothing serious tough, love your work.

Thank you!
Two different expiry dates, with a medium term release, is a great idea!
Scratchpad still doesn’t work, however I don’t use it.
Thank you again

Thanks guys, you’re freakin’ heroes. Working fine on 64bit Lucid.

magicfingers, was the previous beta working for you, and did you install using the --force-architecture argument?

Thanks for asking! Yup, no problems up to this point, and yup, you can’t exactly install it without --force- architecture. The “rename rtfi” workaround works for me in Lucid, so I’m a happier camper at this point.


Success from openSUSE 12.1 x64 after installing all the required 32 bit versions of all libraries.

Tip: Run Scrivener from a terminal to see any error messages and then use Yast2 or zipper or System Settings -> Software Management to install anything that is missing.

… how did you get the spell checker to work on 64 bit Lucid?

Whenever I try to install the 32 bit aspell libraries, Lucid wants to remove roughly 80% of my desktop.

I’ve tried installing on Ubuntu. Scrivener opened with error notices (the RTF reader failing) and now does not show my text anymore. :confused:
I have to admit I’m new to Linux, so I probably did something wrong.
Just used the terminal to install the deb, nothing else. (Scrivener worked fine before this update)

(I’m running 32bit Ubuntu 12.04)

slashedkaze check out the forum post about rtfi reader not found. There is a working solution posted there.

You can also do “ldd Scrivener,” too. That will show you every library it needs. It should point to Scrivener for all of the Qt things, but it’s going to need some system libraries, as well.

Uhuhuuuuuu! :slight_smile:

After some time to find out the right libraries i got it running under Debian Wheezy 64 bit & Fluxbox :smiley:
Finally! But nativ 64Bit support is really needed, because i think i fuck up my clean system ahahaha

Most distros will put 32-bit libraries in a different place than the system ones. You can set the LD_LIBRARY_PATH to look where they’re installed. It’s not a good idea to put optional libraries in with system ones…

RPM Version for OpenSuse and similar. :slight_smile: : http://www.sendspace.com/file/o8uc9n

Also, I’m still having the problem I had with the last beta, which started when I had to get a new harddrive. I’m thinking it’s probably something in my settings/packages rather than Scrivener this time though since a Google search shows other people getting the same error message trying to run other programs.

I ran the above command, and all the libQt entries are listed with the correct location.