LINUX Beta Released

Please read and Windows beta posts for background info here -> [url]https://forum.literatureandlatte.com/t/beta-1-5-0-6-released/20377/1] Scrivener Linux tar Package here - > http://www.literatureandlatte.com/scrivenerforwindows/Beta/Scrivener- Scrivener Linux deb Package here - > http://www.literatureandlatte.com/scrivenerforwindows/Beta/scrivener-


  1. OPML Import
  2. OPML export
  3. Mind map import (Freemind .mm format)
  4. Mind map export (Freemind .mm format)
  5. CSV export
  6. Import and Split functionality
  7. Import Scrivener Project functionality
  8. Image background (texture) in full screen
  9. Comprehensive Print preview functionality
  10. Print index cards
  11. Print outliner
  12. Inspector comments and footnotes
  13. Revised annotation, footnote and comments options
  14. Scrivener now speaks:-English, Chinese, German, Italian and Sci-Fi. French, Spanish, Russian, Polish underway
  15. Second phase of performance enhancements - Scrivener is faster again
  16. Implemented Cancel within Compile dialog i.e. changes are no longer saved when Cancel is clicked
  17. Project and Preset Replacements added to Compile dialog
  18. Deleting Scrivener project files within the directory of an open Scrivener project is now prevented
  19. Options->General - added checkbox to show full project path in title bar
  20. Added “Take Snapshot” menu item in header bar i.e. right click document icon to see sub menu and added ability to sort snapshots
  21. Improved debug and minidump reporting



The new minidump is supposed to make a minidump directory in the root of the Scrivener directory, right? Had a crash, no minidump directory. Nothing in ~/.local/, either. And should the Scrivener home dir stuff be in ~/.local/share/data/Scrivener/Scrivener?

Linux Mint 13 KDE 64bit.

Downloaded *.deb file, installed from command prompt using sudo dpkg -i scrivener- which overwrote my old install. Opened and it works great. Checking out new features now.


I never experienced any of the traditional 64bit issues or the missing lib problems with my original install of the last version. I think it may have been because I installed Mint with Mate originally and then installed KDE using apt-get. YMMV

Whohooo :slight_smile: is already X-MAS? good present! thx
downloaded and will test it tonight!

Sadly, still crashes when trying to add files to the binder. Changing the language of the user-interface (e.g. to german) don’t work for me, always stays in english. :cry: I am using Mint 13 - 32 bit

Tried installing *.deb via Ubuntu Software Centre (Ubuntu 12.04 LTS)

Got this warning message while trying to upgrade …

The package is of bad quality

The installation of a package which violates the quality standards isn’t allowed. This could cause serious problems on your computer. Please contact the person or organisation who provided this package file and include the details beneath.

Lintian check results for /home/[username]/Downloads/scrivener-
Use of uninitialized value $ENV{“HOME”} in concatenation (.) or string at /usr/bin/lintian line 108.
E: scrivener: maintainer-name-missing lee@literatureandlatte.com
Use of uninitialized value $name in pattern match (m//) at /usr/share/lintian/lib/Lintian/Check.pm line 197.

I got “The package is of bad quality” warning too when installing via Ubuntu Software Centre. I assumed it was because I run a 64 bit system and Scrivener is compiled for a 32 bit system. I just told it to install anyway. It did, and everything is fine.

Newest beta, 32 bit Slackware 13.37, so it’s not suffering from the 64 bit multilib oddities.

I’m trying to insert a jpeg, something I know I’ve done before. Insert > image from file doesn’t give an option for “all files” or jpg/jpeg. Typing the file name directly doesn’t work. I can insert an image using WINE/Scrivener, then open the project in the Linux native Scrivener and view the images just fine.


My scrivener doesn’t speak italian. Thanks anyway for the new version.

And the insert image thing works just fine on the desktop (Arch Linux, 64-bit.) Go figure. (Can’t use the add file dialogue without it crashing, but I can insert an image.)

Keep in mind that this new release still requires the user to follow the steps I detailed in the post “Got 1.1.0 working on Mint 13 Cinnamon (64bit).” Essentially the 32-bit libs still have to be installed and the force architecture command utilized.

Best of luck.


First, let me say that you have a killer product; your attention to detail shows an exemplar understaning of your market. No surprise, since you are, after all, part of your target group (writers).

This may sound like criticism… but I hope you understand that it could be also very valuable feedback…

The last two releases added exactly zero features that I cared for.

Given how far appart relearses are, and how many incredibly useful features the Mac version has (that I do want!), I’m not sure development is going in the right direction. Take this as my very personal view.

Does anyone suppose that the Linux version might one day run on a Chromebook?
Chrome OS is a variant of Linux. But it mainly runs web-based applications.
Though some are “offline” and it does have a file manager.

Apologies if this has been asked and answered already.

This is a question to the developers of Scrivener, how can we know? I am more interested in a stable linux version in the 1st place and this will need time…after this, sure it’s possible that someday we will get versions for Chrome, Android & iOs

But, if Chrome is based on Ubuntu/Linux than i think it’s no big deal to install the linux-version on your Chromebook

There is an iOS version in the works, and I think they are planning on Android after that.

I haven’t tried the ChromeOS, so I can’t speak to it. Since it is a Linux variant, and if it can run offline programs, Scrivener should work. It won’t run in the Chrome window (the browser) though. Well, I’d be surprised if it did. How about that.

All that being said, in looking at the stuff Google has up about the ChromeOS, I’m not sure it will. You’d have to find a way to install it, and not from the Google Store. That isn’t to say it’s not possible. I’m just leaning towards very difficult if it is.

As always, thanks to everyone on the Scrivener for Windows/Linux team for your great work. Bravo. I just used dpkg to load it onto my Dell Studio laptop running Ubuntu 12.04, and it has so far worked perfectly right out of the box.

One question: I didn’t see what the expiration date for this beta is, assuming that we do all somehow live beyond Friday the 21st.

Am I correct in thinking that Sync With External Folder is still missing from the Linux version, or have I simply missed it?

I would very much appreciate having this feature (which I know exists in the Mac version of Scrivener).

Echoing the expiration date question, and subscribing to the thread. When installing the Linux beta, it still says it will expire on July 31, 2012. The info on the Windows beta says it expired on December 21st. The Linux version is still working, of course, and I’m pretty confident that there’ll be a new beta by the time it expires, but it would be nice to know in advance when it’ll stop working.

Anyway, just now getting around to taking this beta for a spin (been using the 1.2.6 beta). And thanks so much for all your hard work on it. Scrivener has been one of my “must-have” tools since I first purchased the Mac version several years ago.

I installed on Linux Mint 14 cinnamon 64 bit. It installed just fine I have the Scrivener icon in the Office section of the Menu, however nothing happens when I click on it. I use Mac OS X Mountain Lion and Linux Mint 14 in unison daily, but am no linux genius, so any help or insite on what I can try to get this to work will be very much appreciated.
Thanks -Mark

Same here, but previously I had no trouble at all. Maybe the beta expired or something.