1.7.1 Mac—>Windows

Has anyone tried opening a project started in Scrivener Mac 2.5 in Scrivener Windows 1.7.1 … a project that hasn’t been opened in the Windows version before?

I’ve just updated my version of Scriv Windows to 1.7.1 — admittedly it’s running through WINE via Crossover in a Windows 7 ‘bottle’ — and to try it out, I thought I’d open a project I’m in the middle of working on on the Mac version. I can navigate to the right place to find the .scrivx file, highlight it and click on “Open” … and nothing happens. The last project I was working on in collaboration with a Windows using friend, opens fine, so I wondered if it was significant that that project was set up by her on her machine … certainly it had been through a Windows Scrivener installation on Windows before I opened it in 1.6.1 on my Mac.

Basically, I’m wondering if this is an artefact of my accessing Windows Scrivener 1.7.1 through Crossover; whether it is due to the Win7 ‘bottle’ as against the WinXP ‘bottle’, in which I ran v. 1.6.1; or if it is something more general.

Please note, I’m more than perfectly happy to continue working on the project using Mac Scrivener, but I thought it provided an opportunity to check out 1.7.1, since the previous project is complete now.

:slight_smile:

Mr X

I just yesterday, for kicks and giggles, updated my Win 7 (running in Parallels 9 mind you only got my first mac this January) Scrivener from 1.6.whatever to 1.7.1 and it had no problems pulling up my Scriv 2.5 projects. I’ll give running it in Wineskin a shot (don’t have crossover) when I get the chance. Just out of curiosity, why are you running it in a Win7 bottle and not XP? Does it work better that way?

Check to make sure your project doesn’t have any duplicate or “conflicted” files (I’m not sure how Cubby would word this, but I’m guessing there’d be some extra text appended to the file name from any sync conflicts). This would cause a project not to open in Windows, although it would still open on Mac, so this could’ve happened a while ago and you’d not have noticed previously. There shouldn’t be any problem opening a Mac 2.5 project on Windows 1.7.1 in general; I did it a lot during testing.

Thanks for this. I’m running it in a Win7 bottle, thinking that might make it run better. The translation project I worked on for a while with 1.6.1 in an XP bottle opens fine. It seems to scroll more smoothly, and generally looks slightly less “hard-edged”; immediate impression is that it runs more quickly, but as we are waiting for the results of the competition, work on it has stopped and I don’t want to change it, but this other project won’t open.

See Jen’s post below and my response when it is up.

:slight_smile:

Mr X

Thanks for the response, Jen.

This is a project which I have saved in Cubby, in case I needed to work on it using my MBP17. I duplicated it using the finder and moved the duplicate onto my desktop to use as a test bed for 1.7.1. When I open the package on my Mac and look at the contents, the “Docs” folder is populated with about 100 .rtf files and two or three links files and a checksum file; there are no files marked “conflicted” or any equivalent. The version.txt in the “Files” folder gives the number “16”. Apart from the fact that I have done work on the main version of the project on my Mac in the meantime so various .rtfs will have changed as will the index, binder files and so on, when I open that package in Finder it is identical to the duplicate one.

However, when I go to open the duplicated version in Win-Scriv, and, without clicking on the .scrivx, I drill down and look in the “Docs” folder, it shows no contents at all, in spite of the Mac finder showing some 100+ files to be present. So on this project, it’s not finding the .rtfs etc. on the former project, it is.

I think I still have a 1.6.1 installer on an external repository I keep of such things, so, unless you have any other suggestions, I suppose I should: (a) re-install 1.6.1 in an XP bottle to mimic the previous situation; (b) re-install 1.7.1 in an XP bottle to see if that makes any difference; (c) move the project into a folder in Cubby where Shirley can try opening it and if she can, see if that makes any difference with the 1.7.1 installation I have.

:slight_smile:

Mr X

Further to that last, I thought I’d open the project using Mac-Scriv and use “save as” to create a copy on the desktop. Same thing … checking the package in the Finder shows a fully populated “Docs” folder, using “Open Existing Project” in Win-Scriv and checking the folder shows it as empty. So, nothing to do with duplication.

I’ll ask Shirley to see if she can open it, and follow that up.

:slight_smile:

New further to that last: :slight_smile:

I put the copy that I’d saved out on the desktop into the Cubby I share with Shirley and gave it time to sync fully. I then asked her to open it, look around, add a comment or something and then close it, which she did. As she was doing so, Cubby reported to me the creation of a “binder.autosave" whatever and changes to or creation of search.indexes and other administration processes. After she closed it, I gave time for all that to be fully uploaded and then had a look. Finder reports the package to have 116 files in the Docs folder, no conflicted files, and it opens fine in Mac-Scriv including her comment; Win-Scriv won’t open it and thinks the Docs folder is empty.

So my first instinct is it must be something to do with the bottle.

:slight_smile:

If you leave Scrivener out of it and just check the .scriv folder in Windows Explorer, do the files show up there? This definitely sounds like a problem with the Windows set up vs. with Scrivener. How is the file being shared with Windows–are you accessing Cubby directly from there? What happens if you try copying the .scriv folder to elsewhere on the Windows VM, maybe bypassing Cubby from Windows too? (I’m not sure how Crossover works and whether this is doable; my experience is with VMWare and VirtualBox, which are a bit different.)

And there was the rub … in CrossOver there doesn’t seem to be a Windows Explorer to access. Just the programs you have installed in their bottles. Yes, it’s very different … there isn’t an installation of Windows as such, so no disk-space taken up by the Windows system. The Crossover installation in the library and pref files combined with the folder containing 2 versions of Internet Explorer and Scrivener 1.7.1 comes to less than 6GB, and no disk space is reserved for Windows use, so it seems to be very lean.

Anyway, back to the problem. I tried creating a new project in 1.7.1 typing in a little bit of junk in a document and saving it to the desktop, with the aim of then opening it in Mac-Scriv, importing the documents for the trial project and then seeing if they would be found when I re-opened in 1.7.1. The finder can’t unearth that project — Spotlight tells me there are no .scriv files on my hard drive, curiously! — but 1.7.1 can find it on a Crossover desktop that seems invisible to OS-X!

So I bit the bullet, uninstalled 1.7.1, shut down the Win7 bottle, created a new WinXP bottle and installed 1.7.1 in it … and it can find my project, complete with Shirley’s comment. So I can use it to see how it goes.

Obviously Win7 on CrossOver has issues. Maybe Garpu, the Queen of WINE, will see this and have some idea what’s going on, though I imagine she will deprecate my having to use a GUI-fronted, already-compiled version of WINE. :laughing:

Thanks for your time and suggestions.

Mark

Hi, I’ve a problem whit my project, I’m write 23 chapter and I save it on mac, i try to open with scrivener on windows but I can see only 17 chapter. I try many times in different ways (save on cloud, save on a ussb pen) but the result is always same. Can someone help?

Crossover (and Wineskin as well as I understand) aren’t virtual machines, they’re GUI front ends for WINE, for folks who aren’t nearly as geekily awesome as others may be around here :blush: . Wine itself is an emulation layer (I don’t know if I’d call it an emulator or not because it really isn’t a full blown emulator/virtual machine). Basically what it does is it wraps a windows program with the barely necessary files for the program to think it’s in windows so that you can run a Windows app in OS X/Linux without actually having to hassle with installing a copy of Windows on your machine. I run my Windows copy of Scrivener in it (mainly just to show Scrivener off to my Windows friends since I work entirely in the Mac version now) along with a few older games that seem to run better in WINE thinking they’re in WinXP rather than my Win7 Parallels 9 Virtual Machine (which I’ve been shocked runs Skyrim quite well :laughing:).

Although, you probably already knew that. :blush:

Actually, yes I did. :slight_smile:

The latest version of Crossover offered the options of a WinXP, Win7 or Win8 bottle. I thought I’d try the Win7 bottle so as to be ready for any update which requires a post-XP version of Windows.

The problem I found that it seems not to interact with the OSX file system, only finding files in a folder on the Drive-C it creates, which is not visible to OSX. So as a collaboration approach, it is useless … the project in question being in a Cubby. But that’s something I ought to take up with the Crossover community.

So I removed that and installed 1.7 in a WinXP bottle and it works, though with other curiosities. The F-keys don’t seem to work, so no Scrivener shortcuts set to an F-key are available; on the other hand, cut, copy and paste are now assigned to Cmd-X,C and V, rather than Ctrl-X etc., which removes one level of frustration. On the other hand, there is a new frustration that if I’m entering a comment and switch to Chinese, the comment loses focus and I have to click back in the comment, double-click the last word to highlight it, then arrow the cursor to the end … and the selection panel for the Chinese character opens right over the entry point in the comment. But that is a minor issue.

Basically, I can collaborate with my friend … I just hope for the day when a solution can be found for the Chinese character encoding issue, so that I can edit within Scriv-Mac … or for the day when she switches to Mac. :smiley:

Mr X