2.0.3 messes up my shortcuts

I created a new document template for a new scene, called “NewScene” that is slightly altered from the standard doc template. I also created a duplicate of the standard text document template, calling it “NewText.” Using Keyboard Preferences, I assigned ⌘N to “NewScene” (referring to Project -> New From Template" and ⌘T to NewText. This allowed me to quickly create new script or new text documents (without having Scrivener pick based on my last use of ⌘8). All worked great.

When I installed 2.0.3, the behavior changed. Now when I have a document or folder selected, and I type ⌘N, it moves the selected file to a spot under “NewScene” in the Templates folder. I think this is because “Move To” has been added to the contextual menu - I’m not sure whether it was there before. Anyway, now, even after I have deleted and recreated the shortcuts in Keyboard Preferences, in Scrivener the shortcuts ⌘N and ⌘T appear in the contextual menu, not the top menu.

Help! I want to be able to use shortcuts to create these two different kinds of documents.

Well, this is strange – I restarted once, after installing 2.0.3. That’s when the problem started.

Then I restarted again and the problem is fixed.

Assuming it doesn’t reappear, sorry for taking your time.

Glad it seems to be working. Unfortunately I have no control over where keyboard shortcuts will appear - this decision is made by OS X. With document templates, the template document (e.g. “New Scene”) will appear both under Project > New From Template > and also under all the various Move To, Scrivener Link and suchlike menus that list documents in their submenus. This means that if you try to assign a keyboard shortcut, it could be assigned to any of the menus that contain a reference to this document, so it will never be reliable. (This is why Scrivener provides Opt-Shift-Cmd-N as a built-in keyboard shortcut for the first template document.)

The only way around this would be for Scrivener to amend the titles of the items in the “New From Template” menu somehow, but I can’t think of a way for that not to be intrusive or odd.

All the best,