2.7 Compile Hanging on other Text Editor Only

So, this is an odd one.

Since upgrading to 2.7, I can compile for PDF, EPUB, or MOBI, but not Word (DOCX or DOC), RTF, ODT, or HTML (cannot export to iBooks with Chapters either, as that is DOCX).

I did not try exporting to any of the screenwriting softwares, as I do not own any, nor did I try exporting to any of the markdowns.

When I updated Scrivener a few days ago, I was still running the latest version of Yosemite. Since this update was partially for El Capitan, I decided to see if the problem went away when I upgraded the OS. Sadly, it did not (on an unrelated note, Mail is working for the first time in over 2 years!)

I’ve tried closing all other programs. Nothing.

When it hangs, it seems to be doing it at the very end. When you start the compile, all the checkboxes that you could turn on or off gray out, like normal, but the color comes back when it hangs at the very end, like it thinks it’s done, but even if I let it sit there for 10 minutes, it still says converting file format, and there is no file, or even the start of a file (like when you are the middle of saving documents) in the destination folder.

Attaching screenshots of the graying out / color resuming, though I don’t know if it will help. Since I am a cross-platform user, until the Windows version of Scrivener is able to edit my files again, this was going to be how I stepped around the issue, but it appears that won’t work either - I’m having to resort to exporting to PDF, copy/pasting, and then editing. Any help would be appreciated, thanks.

Could you please send a sample project showing this issue to mac.support AT literatureandlatte.com?

Thanks and all the best,


I have sent you an email with a (different, but same problems occurring) project (the one I sent is MUCH smaller to make things easier). My first name is Eric and my name is in the email. I provided a link to this forum so you all would know the corresponding forum thread.


One other quick update - just to see if it was a problem caused by updating a project from an old version of Scrivener, I created a brand new project - same thing happened, can export to viewing file formats like PDF or EPUB, but not editable like DOCX.


Key Keith,

I turned on show internal errors like you suggested and it showed quite a bit - I responded to you in email, if you want me to post them here, let me know.



After a few emails with Keith, I thought I would post the solution in case others had the issue.

After reading the error report, Keith determined that Scrivener was missing files needed to complete the compile process to those formats. He suggested I uninstall Scrivener and re-install Scrivener.

This worked eventually. Turns out, 2.7, when I hit “update” from 2.6, didn’t replace 2.6, but instead installed a second installation of Scrivener. Once I deleted both of my existing installations, I was able to re-install and my solution was resolved.

Re-installing is very easy - I didn’t even have to re-enter my serial key, apparently somehow that had been saved on my Mac - if I had known I wouldn’t have to go digging through my files for the key, I would have tried a re-install before ever contacting Support.

Thanks Keith for all your help!