2.8.1: Consistent crashing on fresh install

Early 2016 MacBook, macOS 10.12.6. The OS was reinstalled last week prior to going in for warranty repair (keyboard) so the OS is fairly clean and there are very few things installed at this point. Prior to the OS wipe, Scrivener was working fine.

I loaded it today for the first time since getting my machine back and opened up a project. Everything looked fine, but then I went to hit a key and Scriv crashed. I tried creating a new blank project: crashed. I nuked the Scrivener and eSellerRate folders out of my ~/Library as a guess (maybe a corrupted config?) but to no avail. The (I hope relevant bits of the) crash report look like so:

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Segmentation fault: 11
Termination Reason:    Namespace SIGNAL, Code 0xb
Terminating Process:   exc handler [0]

VM Regions Near 0:
    __TEXT                 0000000000001000-0000000000372000 [ 3524K] r-x/rwx SM=COW  /Applications/Scrivener.app/Contents/MacOS/Scrivener

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   com.apple.CoreFoundation      	0x941e7ef2 CFDictionaryGetValue + 34
1   com.growl.growlframework      	0xc0001e67 +[GrowlApplicationBridge isGrowlRunning] + 81
2   com.literatureandlatte.scrivener2	0x002d9585 0x1000 + 2983301
3   libobjc.A.dylib               	0xa0cc01be CALLING_SOME_+initialize_METHOD + 31
15  com.literatureandlatte.ScrAppKit	0x0058dff8 -[KBTextStorage replaceCharactersInRange:withString:] + 556

I’ve tried a re-download and re-install as well, to no avail. I’m open to deleting other config files etc. as needed to try to get this resolved, and I’m comfortable working at the command line if needed. If anyone has options to try, please let me know.

A system reboot has resolved the issue.

System reboot is the secret remedy many IT specialists use to fix problems. I once had a similar problem on a PC but reboot didn’t fix it. So I asked for professional IT support. When I came back from lunch he had fixed it. I asked what he’d done but he was reluctant to tell me. He finally admitted that he had rebooted the PC. “But so did I, to no avail?” I answered. “… until it worked as it should,” he continued. “Six or seven times I think” he said with a big smile. :slight_smile:

“Have you tried turning it off and on again?”