2 x regex weird

Beta 26 / Win 10 ver 1803

Action: Ctrl-F, enter ^$ as Find string, Hit Next.
Actual result: “Not found” message shown
Expected result: Instances of blank lines in document are found.

Action: Ctrl-g ctrl-s, enter ^$, hit enter
Actual result: What looks like every document in project is shown in search results binder
Expected result: Only those docs containing blank lines are shown in search results binder

Please, have a look at the other similar thread and my comments within:

I see no way in B36 to remove blank lines in bulk, either in the manuscript or as a compile operation.

Am I missing something?

Have you tried Edit->Text Tidying? Also, what about the “remove trailing whitespace from documents” in the compile window (right side, under the gear icon)?

Yes I have. Edit->Text Tidying->Remove Empty Lines Between Paragraphs works on only one document at a time, and by ‘bulk’ I meant multiple docs, or ideally the whole manuscript.

I have tried the trailing space option too but this only removes blank lines at the end of a doc, not within (as the name of the option implies).

Text tidying should work on all documents loaded to the editor. This may be a bug.

Text tidying appears to only remove blank lines from the document in which the cursor currently is, rather than all docs loaded in the editor.