22: use formatting in current editor is greyed-out Why?

What am i doing wrong.

I change the formatting defaults, and the “Use Formatting in Current Editor” is greyed-out. Is this expected?

New projects do conform to the changes (font and size, indent, line length, spacing).

How do I apply the default formatting to selected text?

“Use Formatting in Current Editor” is greyed-out. -> Place your mouse cursor inside the editor and the desired text, which formatting you want to use. This should enable the button.

No joy. You?

Doesn’t work.

Click in text I want to change, still grey. Select text I want to change, still grey.

Select in the binder, still grey. Put mouse inside editor, still grey.

Nothing un-greys that box.

Version: Beta (664545) 64-bit - 27 Aug 2019

I got it to work - but there’s definitely something wrong in the code as the function is not working as expected.

Here’s the recipe that works for me:

  1. Select the text in the editor and change the font. De-select.
  2. Press F12, then go to Options > Formatting. Button is greyed out.

  1. Double click the sample text in Options to de-select it. Keep options OPEN
  2. Click in the editor
  3. Press F12 to return Options > Formatting to focus. Button will now be active.

Whoa Russ!!! That was determination to find that solution.

You get extra cookies tonight.

And thanks.

That’s a lot of work to use a button, when I can use Ctrl+A (select all) and then click “no style.” (which may not work for all people, but it’s been working for me)

And, yeah, good work, Russ.

Thanks, friends. Beta testing is an enjoyable game for me…

I completely agree - that is a bunch of steps for what should be a simple, intuitive function.

Which is why I think there’s a bug at work. I have a suspicion it’s something UI-related because the function/button becomes available after Options loses focus to the editor and then regains it.

But, I’m not a coder. That’s for people smarter than I… the job of a beta tester starts with: “I wonder if I can break it…” :smiley: