27 in screens text size very large

i have a 27" LG monitor andd get this : snapshot below.

here is what i did to fix this problem, but i don’t like the solution : made program compatible with windows 8

This is (or should be) unrelated to the size of your screen.
Scrivener’s GUI setting is in the options :

[EDIT] I am not quite getting the same result as you though. For e.g. I don’t get a huge font in the labels or status (bottom right).
There might be something else at play. (Your menus should have been big too)
Seems selective in your case. (See how in your screenshot “no style” is huge but the rest of the format bar isn’t? I can’t explain that.)
Likely not a Windows setting (?), as I’d otherwise expect your top bar etc to be huge too.
(Still, you may want to make sure everything is normal in Windows’ ease of access vision settings and Scale and layout settings. Although I can’t reproduce what you get.)

Is this new? Or as it always been like that?
Is this your primary monitor?