3.0 Release - two problems - only!

Smiling, as I am very happy for your fortunate release, and these are small things.

  • I couldn’t succeed at paying for the upgrade license, because the Paddle dialog failed at the point of clicking to use PayPal. The hand cursor shows, but nothing happens on clicking the PayPal button. The credit card button looks as if it operates, just I don’t give out card numbers that easily. I saw what may be a related problem reported, and I know you’ll have this run down soon.

  • the other problem is kind of a normal thing with Betas - something is not right finally with the registry. This shows up in two ways, possibly related: I have a picture of one of them.

  • After I de-installed the last RC, and used Control Panel to remove indication remaining of another recent install, and completely deleting c:\program files\scrivener, capitalized, I found another install indcator turned up in the main Settings:Apps list. This one can’t be removed by either Settings or Control Panel - doesn’t show in Control Panel. I may have an idea about this, though…

  • more seriously, but surely out of some registry items left around, Scrivener reports it’s not running out of the correct folder, with much dire prediction if you don’t fix it. Except, it is actually running out of Program Files/Scrivener3. I not only checked, I started it directly from there. Another de-install-install cycle didn’t fix this. Here’s the image, and I guess I will have to find another free version of Revo hopefully - a bit busy for that tonight - and cross fingers.

Here’s the image for that, and cheers…


Ok, I managed to pay and get the license, so here’s how:

  • I just gave up and closed the window on the original purchase.

  • I did try going in again, found it remembered my discount code, which is nice, but still no PayPal forwarding

  • then, a while later (half hour?) hour? more?) I got an email from Paddle, saying I hadn’t finished the purchase. Right.

  • I clicked on their button, was presented with the same funny dialog, with discount filled in

  • I pushed PayPal on that version…and it opened PayPal properly for login…

  • …in Chinese…

  • cutting to chase, I fixed that by logging in on a separate tab to PayPal. English again. Then refreshed the Paddle Chinese PayPal tab, and it changed to English. British, anyway :slight_smile:

  • I completed the transaction in the normal way

  • and got instant email with the serial number. Now easily twice as long as the long original.

  • I put the license in, pushed the Activate button…waited…a loooonnng time…and Accepted

  • you guys get one giant pizza, to be shared across several waters :slight_smile:

Just to say, I looked further into the registry, found an assortment of old /Scrivener paths, each time next to new proper /Scrivener3 paths. So I may take those out tomorrow or so. But a better solution would be welcome, as Don’t Try This At Home!

I doubt there is a better solution, as Revo didn’t know about the old install, and zapping automatically such strings would mean the very non-recommended use of a ‘registry cleaner’. Don’t try that at home, or in the shop either, is best advice as far as I know.

I just purchased the upgrade as well and my paypal window opened in a Internet Explorer popup!
I didn`t even know that I still have that shit on my computer.
So if you don’t, this might be the reason for not working. I already postes that in the feedback section of the forum.

Interesting, I didn’t run into any path issues when trying various beta → final transitions (including just lazily installing right over the previous beta). I wonder if maybe you had a lingering issue from a very old beta that wasn’t cleaned up in newer uninstallers?

Well at least it is all working now—and yes the PayPal thing very likely is an issue of not having ie.exe installed on your system, or having it blocked. The solution is to use the store page page instead, to finish check-out. The only thing you miss out on is auto-activation.

I had a very similar experience to narrsd and austriaka when trying to buy the v3 Windows license.

All was going smoothly up until attempting the Paddle handoff to Paypal, at which point I got a spinning wheel in the Paddle Checkout window. Apparently Paddle couldn’t reach PayPal. I even tried the ‘Click here if PayPal doesn’t open’ link, but PayPal still wouldn’t open.

I closed the Paddle window and tried again from Scrivener, by clicking on Buy Now.

No joy. Same spinning wheel on the the Paddle handoff to Paypal.

I was about to give up and wait for the email narrsd mentioned–but then–while staring at the spinning wheel in the Paddle Checkout window, it’s just dumb luck that I noticed something happening on the screen underneath the Paddle window.

When I moved the Paddle Checkout window out of the way, I found underneath it a similar-sized Paypal login window had launched–in IE! As austriaka said, I didn’t even know I still had IE on my PC. :unamused:

Who knows, maybe the IE window was also there during the first attempt.

After logging into Paypal, rest of the payment process went smoothly.


I have the same problem: clicking on the PayPal button does not work (presumably due to missing ie.exe). What other option is there/how does it work exactly?

I believe the solution mentioned in this thread might also work for you: [url]https://forum.literatureandlatte.com/t/solutions-paddle-license-engine-fails-in-wine/95090/6]

Give it a try, I hope that helps.


1 Like

Many thanks for the quick reply, Jim!

And another problem… Going through the activation process, it tells me that my V1 license is not valid for V3 but then tells me to go through the upgrade process. That works at first and I get my upgrade token. The problem is that when I click on the buy button again to use that token (why did this not happen in a single step?) the Paddle process crashes and I have no option but to cancel and try again, which merely gets me the same result.

Obviously, the Paddle process worked well enough to try to validate the V1 license and to issue the upgrade token. Why then does it crash when attempting to use that token? Just as importantly, why did it not detect that an upgrade was applicable and simply activate Scrivener in one simple step, rather than this unnecessarily convoluted process?

Where does this leave me? I’m stuck with a valid V1 license that qualifies for the V3 upgrade but cannot use it because of a software problem with the third-party activation software. How do I get past this and get V3 activated?

If by “upgrade token” you mean Paddle provided you the discount coupon, then copy the discount coupon and try the solution in the thread I linked to above, as it should work for you.


Are you using Linux, as your signature indicates? If so, you’ll probably have better luck looking for solutions in the Linux subforum rather than Windows. Here’s where I would start for instance: [SOLUTIONS] Paddle License engine fails in Wine.

I think JimRac’s giving a best answer here.

Your crash problem may also have to do with Paddle somehow insisting on running Internet Explorer. You may have an out-of-date one, and anyway, Microsoft has discontinued it.
That I had actually removed it (IE) from my machine long ago no doubt accounts for my issue, and addressing the update from a good browser, pasting in the code, worked fine.

In my case that ‘paste’ happened automatically, by the route I got to the page, but I’d already saved it in case needed, as you can and then use it.

Best fortune!

(and thanks, Ioa, for your explanation – you guys ought to talk to Paddle about this :slight_smile: Am sure you are…)

I had a similar problem yesterday, but found that the PayPal popup opened behind the Paddle window. I moved Paddle window and I was able to use paypal without problem.