Hi Beta Testers,

Windows and Linux Beta 022 is now ready for download at scrivenerforwindows.com.

In this beta we have started to add the finishing touches and our first round of performance improvements.

First up, you will notice quite a few new menus - we still need to add others and assign additional shortcuts; however, things are taking shape nicely. You’ll also notice the addition of a subset of the trial mode functionality of our 30 non-consecutive-day-trial. These things are always a little nerve racking to implement so we decided to trial the trial to ensure it works and weed out an early bugs. You will notice a ‘Reset Trial’ on the message box on start-up. This will ultimately be replaced with a ‘Buy Online’ button, but for now I thought it better to add a reset function just in case a trial ends prematurely or other folk start playing around with the Windows registry keys.

Anyway, I’m hoping you’ll find this build another step up from the last. Here’s what’s been fixed (1-24):

  1. Crash - If you click the very first document in the binder, then press and hold the down arrow key, Scrivener will crash when it gets to the end of the binder.

  2. Performance - binder performance in general should be between 500-1000% faster than previous.

  3. Performance - loading large documents. We trialled a 364,440 word (2,361,934 characters) in a single document. First clicking the down arrow in the binder through a series of other docs until one hits the 364,440 word document took about 7-10 seconds to display. If one kept pressing the down arrow past the document it would take another 7 seconds just to select the next document. Now binder navigation is instant. The loading of the document in the first place has improved and we’ve added an animated progress bar for all larger documents in general. We can confirm that further improvements to performance are possible once we implement layouts for 2.0, ultimately it is unlikely that such large (unrealistically so) documents will take more than a second to load.

  4. Lots of new menu: Scrivener Links, Outliner columns, spelling, upper to lower case etc.

  5. Group View/Editor View control now works as per the Mac 2.0 version.

  6. We have added a project replace function.

  7. Ability to arrange items in collection.

  8. Ability to drag and drop new items to collection from corkboard and outliner.

  9. Ability to remove trash can dragged into collection.

  10. We have added a fix for the ‘7Zip bug’ for the 0 byte zip problem.

  11. Added .ODT (Open Office) export back to compile menu.

  12. View>Binder Affects>Alternate Editor with a document highlighted in binder research area will now open the binder element with the system default editor for it’s file type.

  13. Inspector icons have been improved and are crisper.

  14. Auto-update has been completely re-worked and the reliance on third-party code removed so that in future we can have a single live update function for both Linux and Windows.

  15. I’m having a problem compiling a short article (499 words) to rtf. I have one letter per line on the left side. The last section, however, compiled normally.
    I had a similar problem and found the possible culprit. Scrivener is compiling one letter per line on text in which the right margin wasn’t set.

SOLUTION: select all paragraphs of the affected text (Ctrl + A) and use the top ruler’s right triangle to set the right margin as desired.

We’ve had a good look at this one and believe that it is a legacy of an old bug. We we’re unable to re-create this in entirely new projects, but in legacy ones where text already existed we could. The solution above remains the appropriate fix.

  1. Compile: Alt-Click in Content and persistence
    Not a big thing, but I noticed that if you select a folder in the Content tab and use Alt-Click to alter the inclusion checkbox for those items, when you jump back to the main draft (or any other folder) this checkbox alteration gets lost. Strictly for the sake of Mac parity, these checkboxes are directly and instantly linked to the data. If you check something off in the compile pane, that is instantly written to the scrivx. I’m not sure if that is right, after all it makes the Cancel button not quite as meaningful, but it does make sense to keep these markings persistent within a single window session.

Like I said, kind of minor because jumping folders isn’t a common thing.
This has been fixed.

  1. Pulsating word target bar - The refresh, subtle as it is now since the last fix for XP users, for the document target bar at the bottom of the editor is annoying many users.
    This has now been given a permanent sedative.

  2. table properties dont display as model and sit on top of other windows when launched.

  3. In the table ‘Rows’ box, highlighting the current contents and typing a 1 will cause the entire Table Properties box to gray-out and become unresponsive.

  4. In the table ‘Columns’ box, highlighting the current contents and typing a 1 causes Scrivener to immediately crash. Admittedly, it’s less likely someone will want 10+ columns, but…
    Again, I tried out other numerals, and the only buggy one is 1.

  5. General observations …If you select a group of cells and then change the background color, it changes only the last cell selected and not the entire group. This may be how Mac programs work – I’ve never used a Mac in my life – but it’s very counter-intuitive to Windows users.

Fixed (for background color)

If you type text in a cell with no color fill and then add color to it, the background color of the text changes as expected. If you then delete that text, the background stays whatever color you chose. This is all expected behavior. No bugs here.

However, if you fill the cell with a background color first, then type the text, then try to go back to a white background (remove the color fill) the background of the text stays filled with color and does not go back to white, even though the cell itself does. You have to select the text itself, then go back to “None” in Cell Background to remove the color fill.

Unlikely to be a simple fix. Will likely need fixes to tables in general. Problem relates to propagation of formats rather than separation of background for cell compared to the text within it. May be possible to just break that link in the short term.

  1. On the Project Statistics>Options tab, the word count per page is set to 350. If I change this, it reverts back to the default when I reopen the option later.

  2. When exporting, I got the file has been exported window several times in a row. No big deal just thought I’d let you guys know.

  3. Use-case: You’ve typed something up and you want to split it in to two separate scenes. Instead of cutting and pasting in to a separate scenes, you decided to duplicate the scene and then cut out the other scene. (Sure, it is more work, but it is still something a person would expect to work.)

Problem: When you do not count duplicated scenes toward the session word count, when the user removes the duplicate sections of the scenes, and all of the removed words count negatively against the word-count, the session word count becomes wildly inaccurate. That is, type 10 words, duplicate them, it still says you typed 10 words, then you remove 5 words in one and 5 words in the other and it reports that you’ve typed 0 words this session even though the Project Total still shows 10 more words than when you started. If you split the scene more than twice, you can get a negative word-count and find that none of your typing for the day moves your session target at all.

  1. Set a Session Word Count of 20
  2. Reset the session target
  3. Create a new scene containing 10 words. I used: 1 2 3 4 5 6 7 8 9 0
  4. Double-check that it shows you at 50% of your session goal
  5. Duplicate the scene
  6. Check the Session Target, notice it stayed at 50%
  7. In the first of the two copies, remove half of the words
  8. In the second of the two copies, remove half of the words
  9. Check the Session Target, notice it says 0%

While it may be cheating to use duplicating scenes to increase your word-count, duplicating scenes as-is results is really poor writing except in use-cases where things are split out.

Allowing duplicate scenes to increase the word-count would cause the behavior to mimic the Paste behavior as pasting increases the current Session word-count.


  1. Is there a way that having the Format Bar and Ruler (View>Layout>Show Format Bar/Show Ruler) to be default? Every time I open a new project, only the toolbar is there automatically.

What’s not fixed yet:
A. Scrivenings mode doesn’t seem to work as it should yet - there is no
way of selecting all of the text or selecting text across boundaries
because it is still implemented as individual text boxes.
We will fix this in a release after launch, once again this is tied to layout implementation.

B. I cannot find the auto-complete feature or how to edit the project
auto-complete list assuming the feature exists.
We will add this in a release after launch.

C. FDX import/export is missing.
We will add this in a release after launch.

D. Can’t import PDF’s for one user:
Can we get a sample of the file? In the screen shot the directory name is ebooks, and if there is DRM involved (often is with ebooks) that may be the issue.

E. The first paragraph pastes as single- I just highlight and reset but it would be nice is style is retained.
I’m going to have to really go into QTextFragment after the release and fix it properly. It just can’t seem to realize the user selected from the start of a block, and always seems to drop first block formatting information. Constant battle trying to work around this one. Not fixed, not simple.

F. I’ve had some random bolding on this version. I run my character sheets like this:
DOB: add text

Age: add text

When I start I knew character I copy and past because the template has the bold/plain text set up I want. When I past the plain text after the bolded text turns bold. Also, later, older sheets that I haven’t edited are bolded. I’ve had it pop up in the middle of lines. For them most part it retains the changes after I make them, but not always. Or in other words, aside from copy and paste, I haven’t seen a consistent reason why some wording turns bold and most doesn’t. I’ve been able to duplicate the problem but not in a consistent way.

The problem has to do with how Qt handles formatting. Its quite deep so unlikely to be fixed for the release as it’s very high risk to all other edit code. The problem starts with the fact that formatting is tied to fragments, which means that the current format is either for the cursor, or if the cursor just moved, for the text preceding it, or if there is none, the default format for the block. That little ‘three cascade thing’ is why there Is a problem. Ideally changing the format for a cursor would ‘stick’ even if you didn’t type, or typed and back-spaced up. That would means the insert format (e.g. What would be inserted) has to be separated from the ‘is there’ format (the text that already follows). This in turn would fix ‘block char format’ stuff and probably a few other things, but is a very deep change to do.

G. Graphs- eeek! This is my least favorite tool, sorry. Setting up the graph’s aren’t the easiest. I can’t highlight a group of boxes and set their color. I have to set the color one at a time. I haven’t been able to copy and paste a graph and retain format so I’ve had to make them individually. Still, it’s nice to have all your stuff in scriv that I hate to make them in word unless I need something really complex.

I set it up this way:
[ Graph]
blank space. (Rinse, repeat three times. )

So the spaces have disappeared, they aren’t retained after I hit enter and egads my data for October, (the bulk of the calendar and definition of tedium) was eaten.

I think this might be related to when I tried add the space, though it was there until I switched to a different screen and gone when I came back, so it might just be a random glitch. I haven’t lost anymore text, but the disappearing spaces between graphs happens consistently when working in dual screen mode, and I was able to create a funky graph by opening it in two different split screens, so I’d just call this feature glitchy.

And just a general question. Is there a way to set the tabs? I can’t seem to find this option.

I know you’ve worked so hard on this program. I really love it and haven’t had much trouble with it overall. Here is a link to some screen shots of the graphs and text.


Ouch! I can see what you mean. Well, the cell background thing I can fix, the rest of the ‘graph’ stuff maybe not for this release. Again its something I’d have to dive into properly, currently they are beefed up HTML tables.

H. Kering query has been taken offline, I’m liasing with Clive to see if we can do anything to improve rendering.

I. Linux - I don’t know if this is a bug, but beta .2.1 doesn’t integrate well into Ubuntu 10.10’s Unity desktop. The title bar doesn’t merge with the top panel. The icon on the left sidebar-dock is blank and doesn’t have the “Keep in Launcher” option.
I don’t have unity yet, but I’m not that suprised. May be fixed by grabbing latest changes to qt, may need to wait to 4.8

J. Linux - Another bug I noticed is that in full-screen view, the inspector icon brings up the inspector window on top as it should but the keyword icon brings up the keyword window in the background where it can’t be accessed. Also, it looks like the inspector in full-screen mode is launching too small; the status and label dropdown menus are scrunched up.
The flags for these windows will need to be os dependent. Will have to look deeper into this later or take a more heavy handed approach to the fix later.

K. Table column widths should not stretch to fit text, but the text should wrap - very annoying. Can we allow for dragging of table widths or is that too hard?

Unfortunately we can not drag and resize tables properly at this point. Best I can do short term is manually entering column/table width information. Still thinking about the long term solution but likely to tie into footers/headers, comments, and edit scrivening fixes.

I. I selected a single file, and looked at the project statistics. Selected is one number, and the count at the bottom of the editor is a different (but close) number. Then, I looked at Project - Text - Statistics. It matches the numbers at the bottom of the editor.

Project - Selected: words = 1633, characters = 8893
Editor bar: words - 1631, characters = 8866
Project - Text statistics: words = 1631, characters 8866

Not sure why the Selected document is coming up with different count, though.

There is a very good reason for the mis-match. Project statistics is based off the compile, which includes things like folder titles.

ii. Also, if I change the options to have more or less words per page, then go back to the Statistics tab (at once, without first closing the window and re-open it) the number of pages in “paperback” option changes, but not in “printed” option. I changed the “words per page” to everything between 100 to 450, and still only “paperback” changed number of pages, not “printed”. This goes for both “Draft” and “Selection”.

This is because we don’t print a paperback. E.g. Changing words per page won’t affect how many pages your printer will print out. “Printed” is a prediction for when you actually print, and is not affected by the options for paperbacks as that’s to get an estimate for publication. Maybe I’ve misinterpreted this, but I don’t think so?

iii. Maybe it’s my expectations as a windows user, but Scrivener’s behavior where focus is concerned seems odd to me.

When I select something in the binder and it brings up the document that I want to see, I expect that the program has focus on that object, so that when I attempt to do an action on the object, like “Find” that it will occur. That doesn’t seem to be the case. The focus seems to be on the item in the Binder.

I’ve run into similar confusion with using the split screen and which part (if any) of the two screens has the focus. For instance

Select Doc 1
Select horizontal split screen
Select the lower pane - we see the gray bar change shade, indicating focus
Select Doc 2
Doc 2 comes into the lower pane
Click on single screen
Doc 1 takes the screen <-- this is non-intuitive for me as a windows user. The lower pane and Doc 2 had focus, but it’s not the one that remains when we return to single screen.

I’ll be happy to do experiments if you need more information or send a long a back up copy of my document if it’s project size that is an issue. Just let me know.

I could not reproduce. Although maybe you clicked on the button that makes the first split full screen rather than the one on the second split?. In which case this is intended (so you can open a view to full without having to change to it first). Using ‘single screen’ from the menu works as expected as well.



Hi! Wow, looks great. Windows version runs great. I think something got screwed up with the linux version on the libs and how they’re linked. I unpacked it, gave it appropriate permissions and got:

/usr/local/LiteratureAndLatte/bin/Scrivener: error while loading shared libraries: /usr/local/LiteratureAndLatte/lib/libQtWebKit.so.4: file too short ]

When I looked into the library directory, the things which should’ve been simlinked were not pointing to the correct library.

For instance (in the old directory):

lrwxrwxrwx 1 root    20 2011-04-09 01:32 libQtWebKit.so -> libQtWebKit.so.4.7.0
lrwxrwxrwx 1 root    20 2011-04-09 01:32 libQtWebKit.so.4 -> libQtWebKit.so.4.7.0
lrwxrwxrwx 1 root    20 2011-04-09 01:32 libQtWebKit.so.4.7 -> libQtWebKit.so.4.7.0
-rwxr-xr-x 1 root   19M 2011-03-25 02:50 libQtWebKit.so.4.7.0[/code]

In the new:
[code]-rwxrwxrwx 1 root  20 2011-04-08 18:01 libQtWebKit.so
-rwxrwxrwx 1 root  20 2011-04-08 18:01 libQtWebKit.so.4
-rwxrwxrwx 1 root  20 2011-04-08 18:01 libQtWebKit.so.4.7
-rwxrwxrwx 1 root 19M 2011-04-08 17:44 libQtWebKit.so.4.7.0

(Think something got borked when it was zipped up. Or I’m too tired and did something stupid, because it’s 1:30 a.m. here. Which is why I haven’t tried simlinking things by hand.)

Thanks Garpu, i will look into the Linux build tomorrow. Lee

Thank you Sir ! :wink:

“You will notice a ‘Reset Trial’ on the message box on start-up.” This little box comes up on the screen, each time the program is run … okay. :smiley:

YAY! Thank you!

…Did you change the date format on the backup filename to yyyy-MM-dd hh-mm-ss? punches the air I didn’t really want to nitpick on this one, but every time I had to backup, I kept having to change it to yyyy-MM-dd-hh-mm because that just sorted nicely in my folders. Easy to find what’s the most recent and so forth. Thank you!

Though… still no dialog box asking me to wait while backing up, huh? :wink:

I know it’s not high on the priority, but if a backup is on a big enough project (my project folder is now 11MB), it takes at least a few seconds. And if I click within the program before it’s done, it freezes up. Half of the time it’ll unfreeze, the other half it’ll crash completely. I forgot last week and went clickity-click and boo! :unamused: It doesn’t have to be an animation, just a “Please wait” and a close button that is disabled–and then a “Backup done!” with the close button enabled at the end of the process?

Also…the “add text” and “add folder” toolbar images seem to have shrunk! They look rather adorable right now, but I’m not sure if it goes right with the rest of the toolbar.


Thanks, Lee!

Binder is MUCH faster. It’s now handling a 115,000-word document without trouble.

What a great start to the weekend.


Ack, I hate piling on. :confused:

My zip files no longer have 0 bytes, but upon trying to extract or viewing the contents, there’s nothing inside. Backing up without zip still works.

Also, I’m experiencing an inconsistent bug where my document inspector does not refresh itself properly. At one point, I thought I’d lost all of my document notes, because I kept seeing the same notes no matter what text/folder I clicked. However, when I went into full screen mode and pulled up the document inspector there, it displayed the right document notes (along with the other synopsis, general details, and associated snapshots). I’m trying to reproduce this but the two times it happened, it took me by surprise and I couldn’t figure out what exactly might have triggered it.

1.) Thanks! (for the linux one)

2.) Confirmed on the zip file with nothing in it. I’ll email it, in case it helps. (since it’s over 1MB.)

Hi Lee,

Thanks very much for this update and hard work. I didn’t have much time to play with it as I’m preparing to leave for the airport. But I did try the compile to docx format and found a road block. I got a message saying the following:

“Could not convert to required format. (May require MSWord to be installed)”.

Well, I do have Word 2003 installed with a plugin that accepts docx documents. I also use Atlantis word processor which can also convert that particular file format.

One question: Is it possible to implement compiling to docx without application dependencies? I assume that Scrivener checks to see if Word 2007 is installed, am I right?

Thanks again. Take care.


Seems much faster, Lee, as you suggested. I assume you know that the autoupdater in .21 doesn’t work to move to 2.2.

I see new find/replace options but it looks like the entire search and replace facility is nonfunctional. Doesn’t work here, under Windows 7.

Cheers — Larry

Okay, I went through and made all the proper simlinks, and the linux native one works. For some reason they weren’t preserved when packaged.


Lots of very nice things – the movable scrivs in Collections a really nice one, and checks out as not affecting binder or other collections.

And lots of bugs knocked off; that was an interesting list.

Verifying the shows-empty zip thing, with 3 unzippers, and that using non-zipped backups works.

I think Compile to PDF may be broken this time, and quite possibly for releases before as I had some silent trouble with this last night. Even on a very short fresh project, it runs for a while, then stops before the progress bar completes, and the result can’t be opened. Compiling to Print, and printing to Acrobat, pdfs are fine.

Could use a progress bar after timeout on normal operations - I had the screen go unresponsive (which greys on Win7) when trashing most of a big project, then clicking on Binder when nothing seemed to happen. Waiting a bit, all came back to working, and all the selected scrivs trashed properly.

Nice change on the filename of backups, by the way.

Progress on other matters - will be getting that to you, for a treat, think you’ll find.

Thanks very much, Lee & crew – this is real progress, even with the few things regressed while working so hard on others – that is Beta, and we fully understand it I am sure.


I’ve reported this bug before, but as far as I know it remains unfixed. Still a problem in Beta 0.22:

Ctrl + Alt + V (Paste and Match Style) works on the regular editor but not on Fullscreen.

Just making sure you’re still paying attention.

Excellent update, by the way. Loving the faster binder. I’m not brave enough to test Project Replace, but I’m so glad it’s there for me :mrgreen:

Yaaaaay excitement! Okay, so. This is just my own little issue. When you finish installing Scrivener updates, the window that pops up has two check boxes - “View ReadMe File” and “Do you want to launch Scrivener now?” It might look a little more polished if the second option read simply “Launch Scrivener Now” instead, rather than having one statement and one question. Again, totally not even a major thing, but it just makes me want to fix it with every beta update. Keep up the good work, guys! Sooooo looking forward to finally being able to pay for this.

Another fantastic release! :smiley:

Out of curiosity, with Scrivener for Windows slated for a June release, what does this mean for NaNoWriMo winners and their 50% off coupons (which expire on May 31)?

We’ve already contacted NaNoWriMo and are issuing new coupons that will not expire until September - we’re just waiting to hear back from Chris, but you should receive new coupon codes on your NaNo winner’s page shortly.


One thing I’ve noticed having literally just opened the newest version for the first time… when I click between files in my binder, opening them in the main screen, the notecards at the side are not changing to match the notecard for that file. It’s just staying on the one related to the file that opened when the program opened.

A smaller thing - somebody else commented in regards to icons for the ‘new text’ and ‘new folder’ buttons. I don’t seem to have these at all, just the drop-down green plus icon as before. Is this correct?

Thank you so much for all your hard work, loving using Scrivener and looking forward to the release :slight_smile:


I have to agree with scribbles here. Doc notes have been an inconsistent problem since, at least, 1.9 (maybe 1.8 ). I think you have some mis-queues in your event binding system. It looks like, from a programmer’s perspective, that you may have click bindings that are different in changing contexts (ie: full screen vs. not). I’ve had more than one panic attack :open_mouth: trying to find missing doc notes. Unfortunately, I haven’t had scribbles luck in switching between full screen to get my notes back. Synopsis is also missing. I’ve also tried a restart to no avail. I also just noticed that it’s the whole inspector panel. It’s not switching when choosing a different document.

Secondly, the total word count is still broken. When you look at the document outliner in a sub-folder, it initially shows correctly. When you switch to its parent, the parent shows correctly. When you switch back to the sub-folder, it shows the single document word count (and character counts) for the Total word count. Nothing but restarting the app brings it back.

Other than those, rather disconcerting bugs, the product is really shaping up.

Hope the comments help you track the bugs down.

Thanks for all the hard work.


Firstly, thanks for all your hard work. I’m so glad Scrivener is finally on windows. :smiley:

I’ve come across a repetitive problem when first using split screen - the text in the bottom pane is always scrambled. Selecting the pane and picking a new document sorts it out, but the next time spilt screen is selected the problem is back. Screen shot below:
Side by side works okay - but if you move from side by side back to full and then to top and bottom, the scrambled text then appears in the top pane … if that makes any sense.

Compiling to PDF and RTF works perfectly on my netbook.

Thank you again! Scrivener has done wonders for my productivity. Love it. Totally.

Also, just discovered that one of the things I kept forgetting to mention or look to see if someone else had mentioned, is now fixed. :slight_smile:

(The last few versions wouldn’t play nice and fit two windows side by side or stacked on win 7, did weird stuff instead, but now it’s behaving quite well, so it doesn’t matter, lol.)

And I’m off to play in Scrivener-land…