A heads up on Crossover

Just a heads up…

Crossover has just announced the release of Crossover 20 for Mac, Linux and ChromeOS. I upgraded on my Mac and tried to install the new RC 11 in both Windows 7/64bit and Windows 10/64bit bottles. In both cases the installation seemed to go as normal, though rather quickly. Unfortunately, Scrivener wont run in either case. I’ll send a report into CodeWeavers in due course.

I updated to RC 11 in Windows 10 running in VirtualBox without problem, though I did that from within the app, not using the installer.exe I had downloaded.


I have the same problem on Linux. Have already reported it with Crossover.

I wonder what is going on, though - it could either be the upgrade to Wine 5.0, or a change within Scrivener itself.

I heard back from CodeWeavers. They said:

I will write back to them to point out that Scriv 3 may be a beta, but I have been using successive Scriv betas for two years. Crossover 20 is the only one that has broken it completely.


I have found the cause: Scrivener crashes if it tries to load the text-to-speech engine. As a workaround, rename the subfolder ‘texttospeech’ inside the Scrivener folder to something like ‘texttospeech_old’. This will prevent the application from loading the *dll file, and allow the application to launch.

I wil also report this to Crossover, and add a dedicated thread here so that people can easily find this solution.

Thanks for this. As a Mac user—therefore typically have no reason to dig into the inner workings of apps!—I presume a Ctrl-click (Right click) on the app icon in the finder will open it up. I will have a look when I have a moment—on my iPad at present, though. If I b****r it up, I’ll be no worse off than I am at the moment!



You’re welcome - and best of luck!


Crossover’s response is perfectly reasonable, in fact similar to L&L policy on OS betas. Hardly any company will expend effort on compatibility with betas. Too many things can change.

The fact V3 beta worked for 2 years is a bonus.

The people at Crossover are very helpful in my experience. Asking them to look into a problem with a beta doesn’t hurt - also since it may help with the further development of Wine as a whole.

Besides, we already know what Scrivener module causes the problems to occur. If the developers at Crossover can implement a fix or workaround for this problem this will help a lot of people.

Yay, that worked. I have it running in a Win-7 Bottle. It required a significant amount of futzing around to locate, but I got there. I guess I ought to post a note of the full path if any other Mac-users need to know.

Thank you for your detective work!



Yes, thank you so much. I was finally able to upgrade to 20.0.2. I tried multiple times with v20 and RC11/12/13 on two distros (Fedora 33 and Mint 20).

I also filed a bug with Codeweavers, but as noted above, they wouldn’t do much because it is a Beta product. As Scrivener is the only application I run in Crossover it was more irksome than anything else. worked fine.

If Codeweavers has already been informed of the “fix”, I won’t bother with also reporting it.

(On Mint, at least, Scrivener 1.9 is able to run on Crossover 20 w/o issue. My wife is still running 1.9 and I put Mint on an ancient laptop to allow her to keep working when her Windows box when it fails)

Should this topic be stickied until Codeweavers fixes v20?

Don’t tell them it’s a problem with Scrivener. Tell them it’s a problem with the Qt text-to-speech engine for that version of Qt – looks like it’s of that DLL.

bugs.winehq.org/show_bug.cgi?id=44386 Is it this bug? It’s been a problem for Scrivener since day 1. It was fixed for a bit, but has a regression.