Activation issue attempting to use both Version 2 and Version 3

I’m running both side by side to work out the differences, but I’ve discovered and issue. Each time I launch the alternate version I get a “Product activation required” dialog. Opening the same version repeatedly has no problems.

Additionally, sometimes opening version 2 after 3 will cause “Unknown activation error Product activation for Scrivener failed with error: -2003”

Thinking that the problem might be related to a conflict in the license numbers and reading somewhere that a version 3 license will also work with version 2 I attempted to deactivate version 2 and reregistering with the version 3 license. However this gives the error dialog “Product deactivation for Scrivener encountered an error.”

The problem exists on both my desktop iMac and my MacBookPro so I suspect it is a general problem. Not serious since both versions do run as registered but it is annoying.

I’m experiencing this exact same… minor irritation, to be honest. :wink:

I can reproduce this, although I’m not sure of the cause because both versions use completely different validation details. I’m looking into it.

After a fun five hours on this, I am no closer to working out the underlying problem, so I have emailed eSellerate for some insight into the matter. I have a feeling it is to do with the older eSellerate engine that Scrivener 2 uses, but I cannot understand how the two serial numbers would interfere with one another.

I do have a solution for you, though:

  1. Download Scrivener 2.9 (follow the “Download an Older Version” link on our Downloads page). If you’ve already downloaded it, re-download, because I’ve made an edit to the code that will make deactivation easier.

  2. Replace your existing version of Scrivener 2 with Scrivener 2.9.

  3. Launch Scrivener 2.9.

  4. Go to Scrivener > Registration… and deactivate your licence. Don’t worry if you see a deactivation error. I’ve made it so that it will remove your serial number details anyway.

  5. Quit and relaunch Scrivener 2.9. (This part shouldn’t be necessary, but it sometimes helps avoid activation issues.)

  6. Go to Scrivener > Registration… and enter your Scrivener 3 user name and serial number.

Scrivener 2.9 can be activated with a Scrivener 3 serial number, and doing this avoids whatever problems are going on with trying to run concurrent activations of two versions, because now the activation is the same for both.

I’ve tested this a few times and it has solved the issue for me, but let me know how it goes.

All the best,

Same problem.
Deleting v2.x for v2.9 will wipe out custom settings, recent documents, etc.
I certainly don’t want to remove v.2 until I have the time to learn v3. Apparently the time required to do so, if my posts and the posts of others of the fora are accurate.
When it rains it pours.

This worked for me.

I don’t know about custom settings, but all my recent documents are still there, unchanged.

Thanks. It’s now working.

Used this method and it fixed the problem for me as well.


Worked for me too, thanks!

It doesn’t say delete. It says “replace”. Install 2.9 right over the top of the existing 2.8.1 Since it’s Scrivener 2.8.1. that now understands the 3.x license, it will preserve the rest of the 2.x settings. You then de-activate, then re-activate.

“Overwrite” deletes the existing program, leaving an unopened program with new settings. I’m not willing to risk overwriting an installation in the hope that installation’s settings will be preserved. On too many occasions these have been lost. I’ll have to go through the program and see if I can export or save these manually before risking replacing the existing program. To complicate matters, there is v2 app store and v2 download with two separate licenses as well as the new v3 upgrade.

Overwriting Scrivener 2.8.1 with Scrivener 2.9 will not - and cannot - overwrite any settings given that all Preferences etc are stored elsewhere. It will no more get rid of your settings than updating from 2.8 to 2.8.1 lost settings (it didn’t). Updating to Scrivener 3 is a different story because it is a different app with a different internal identifier and so does not use Scrivener 2’s settings.

Just to confirm, I too have the initial problem with both versions of Scrivener (2 &3) requiring product activation on first start-up. I haven’t tried the fix yet, but I can probably live with it for now, and hope to migrate fully to 3 fairly soon.

The deactivate and replace didn’t work for me on my laptop. Version 3.0.3 installed no problem then I tried to install 2.9. Oh my…

I deactivated my v 2.81 copy, installed 2.9 and no matter which serial number I used, it kept telling me it was invalid. I copied and pasted, tried entering manually… didn’t matter what I tried…

Finally, I tried registering 2.9 with my name only and no serial number. I saw my old one flash, disappear and then it gave me the familiar access error … Been here before. I quit 2.9, started 3.03 then quit. Then I started 2.9, got the access error and quit. When I restarted 2 again,. it worked and I could switch between the two versions again.


Worked for me, very relieved as this was driving me nuts. Too bad the eseller people can’t solve the problem on their end, but all’s well that ends well.