Adding custom words to Scriv dictionary?

I am having a frustrating problem where Scriv will allow me to add SOME custom words/names to “Learn spelling” but NOT all.

This is mainly happening with names. Here are two examples:

Dince as a name gets corrected to dunce or some other word. I have no option to learn the spelling.
Ril as a name gets corrected to Oil, and again, no option to learn spelling.

There are a number of other words, not all names that I cannot think of right now. Is there a way to manually have Scriv learn these spellings?

This article is a bit old, but I I hope it is still useful:
https://www.macobserver.com/tmo/article/os-x-fixing-autocorrect-issues

Autocorrect is the best and also most frustrating feature of modern software. It sounds like part of your problem with being able to add words to the dictionary is that you can’t stop the autocorrect from happening.

You can stop autocorrect by hitting the ESC key (before hitting space, which automatically selects the autocorrected choice). The word, as you typed it is then left in place. You can then add it to the learn spelling list by right clicking it.

You can also stop autocorrect by using your mouse to click the ‘x’ in the box that pops up showing what autocorrect will do. However, if you are a fast typist, you will often already hit space before you see the box. If you do, you can use another method to avoid autocorrect and allow learn spelling. If a word is autocorrected, and you don’t want the autocorrection, simple backspace over the word and type it again as you want it. This should disable autocorrect on that word, and then you can add it to the learned spelling list.

So, to summarize, three methods to avoid autocorrect:

  1. Type ESC before space to avoid autocorrect
  2. Use the mouse to click on the ‘x’ in the autocorrect suggestion popup.
  3. Backspace over an autocorrected word and retype it–this should avoid autocorrect on that word.

Thanks, I will try that. Oddly, autocorrect isn’t even working now - so I can type those words. It’s a little frustrating to say the least.