Adding links to web pages

I used Scrivener a few months ago and now I have a new legal deadline and I can NOT figure out how to add the links to web pages as I did a few months ago. I just PAID for Scrivener because I liked how I could organize, but this is about as frustrating as it gets.

I have ZERO recollection how I added the links with the Firefox icon. Tried adding a text note and paste the link, but that doesn’t work.

Can someone please tell me how to do this?

Probably you did it with Add > Web Page and then selected Import As: Webpage Complete (MHT).

This imports the entire page into Scrivener, e.g. for offline reading (with Firefox you will need an add-on to read this MIME HTML archive format. However the actual link to the online page is provided too, in the footer bar in Scrivener, not shown on your screenshot though).

But: If you only need the link (when online) you could use Document References instead or simply create a document with a link (or many) in the text body using Edit > Link…

Hi Christine – If you’re actually viewing the desired page in Firefox, drag the token just to the left of the URL into Scriv’s editor.

Rgds – Jerome

Thanks, now I tried dragging the link again and this time WAITED a long time (previously gave up, thought it wasn’t working) and I ended up with links with the IE icon and of course they also open with IE (which I really don’t like).

Also, as you can see, it doesn’t show the FULL link and the background is white instead of grey.

When I try to IMPORT a web page I get several pdf options, plain text and complete webpage (MHT) – which would be great if it worked! It also states “Note: only plain-text can be imported into the Draft folder”

Again it turns into a IE page, takes a long time and it looks AWFUL, I’d rather just click on a link.

I know I’ve upgraded Scrivener, did something change to turn all web pages into IE?

Maybe you have inadvertently changed your standard browser to IE? Anyway, if you are happy not to have the web pages for offline view, just create one document per link and insert the link into this document’s text body or use the Document Reference. Both options are shown in this screenshot:

The footer bar can be switched on with: View > Layout > Footer View. So even with the cumbersome MHT import it should produce this:

Problem is everything opens with IE in Scrivener ONLY. I haven’t even seen IE in I don’t know how many months … don’t use it. I’ve looked for options in Scrivener, but couldn’t find one for browsers.

And, considering that the whole idea of Scrivener is to be able to ORGANIZE, I want my FireFox icon.

That may be hard to understand for you, try filing a brief in a US court of appeals some time without the help of a lawyer. I have at least three other organizers I chose NOT to use for this project.

I’ve sent this page to support, seems like there must be some setting somewhere that I missed.

Are you sure Firefox is still your default browser? Edge in Windows 10 tends to be a little grabby, for example, and if you run FF directly you may not notice the heist. In Firefox Tools > Options > General to ascertain and fix.

Rgds – Jerome

“Firefox is currently your default browser”

In fact IE of course wanted me to switch to it for browser earlier too.

FYI, am running Win 7 Pro 64.

This is just weird because back in April there was no problem. And I haven’t made any changes that I’m aware of.

Really surprised then that Scrivener brings up IE on links. Wonder if it’s interrogating a registry entry that’s contrary to the default. Just a thought for the devs.

Rgds – Jerome

Thanks for your input.

I also feel like it’s not my computer because dragging a FireFox URL to Scrivener turns it into IE. And the old links kept the FireFox icon.

And one more update. I tried Chrome and kept getting the import menu when I was dragging the URL to Scrivener. Thought I’d restart my computer (lost a bunch of work in the process), but that didn’t help at all.

Now it doesn’t matter which browser I use, I get the import menu when I try to drag a link to Scrivener. Chrome gives me errors. And I really don’t want to import. I’m thinking that it took so LONG earlier because it was actually importing automatically (something, don’t know what), but this is really BAD!!!

Also tried a different project, same problem, get the import menu.

Is there a way to downgrade one or two releases? I see that my last URLS were properly added May 21.

I just checked. Upgraded yesterday. I really need to UNDO this upgrade.

Here is the response from support:

Looks like I’m not the only one having problems.

And this isn’t just an “inconvenience.” I upgraded to Version 7.2 (64-bit) Does anyone know how to UNDO this upgrade?

OK, that part should be easy. Try dragging the URL token into a folder in Windows Explorer, or onto your Desktop. This should create a Windows Shortcut. Now try dragging the new shortcut into Scrivener’s Binder. You may get the “Import Files” prompt, which is different from the “Import Web Pages” prompt. But you’ll see there’s a checkbox to turn the prompt off for next time.

After you’ve OK’d the prompt, you should have a clean link from the binder. The icon though will most likely be a shortcut wrapper over the icon of the actual web site to which you’re linking. You can change that by right-clicking on the entry and selecting the Change Icon prompt. Perhaps you already have a Firefox icon in your icons set? Otherwise you can add one through the Manage Icons prompt.

Rgds – Jerome

The Url from the desktop didn’t give me any menu, went straight into the binder.

Appreciate your help, since I’m facing a deadline I’m going to use another organizer and will get back to this after the 22nd. Hopefully I’ll get some use out of Scrivener eventually. Suppose I’ll write a book :slight_smile: