[Aeon Timeline] Copy content of custom metadata to other project! "End" value is skipped

Everything works fine, as such, I use these metadata names in connection with sync to Aeon Timeline: Start, Participant, Observer, Author, and Event Arc.

I have then added, after Event Arc. the field “End” because I needed that info. (born-died)

When I then use the ‘Copy to other Project’ option all info is copied, EXCEPT the content of the “End”. I have looked in the forum and in the manual but not really found a solution! Could it be that it is because “End” is a field added later (not from start)??? or!!!
Kind regards

Palle Jensen

To clarify one thing, as the Documents ▸ Copy To Project ▸ submenu works on selected binder items, does that mean your metadata is in a document in the binder, rather than stored in the compile settings somewhere? If it is the latter, I’m not sure how that is working at all, or maybe you’re doing something I’m not thinking of immediately.

Otherwise, I have in the past noted that Copy to Project seems to source from the saved copy on the disk rather than what is in memory. This is likely down to a technical limitation, but it does mean that if you have auto-saved turned down so that it triggers more rarely, you will be sending older copies of data more often. I believe the same occurs if you drag and drop between binders as well, rather than using the menu command. To be sure, use the manual Save command before trying again.

I am by reflex always saving to disk ctrl S, so this should not be the cause.
I have relied on custom metadata from the very start, since I sync most projects to Aeon timeline. And there has never bin any ommitions. Just for this recent added custom field “End”.

I may test if it is happening if I move the End up from its present lowest placement
Still I am curious about this “nonlogical” behaviour.


Ah, custom metadata! Sorry I was thinking Markdown metadata, which one might type into a file and then copy to another project.

Okay, well that does make more sense, because it does this on purpose (even if the logic may not be obvious). This is to avoid “central archive” style projects from accumulating massive lists of junk fields from all of the satellite projects that feed into them, or even on a lesser scale, one book’s specific tracking devices which might be of no use to the next book’s.

There is however a way to “opt in” to metadata being copied, and that is to make sure the target project has the field set up, by the same name. Once that is there, it will be more aggressive about adding new data, even adding list entries to List style fields, if the value hasn’t been used yet in the target project. So just make sure the target has all of the fields you want copied, and you can meanwhile be safe in knowing completely irrelevant fields will remain ignored.

By the way if you didn’t know it, you can open each project’s Custom Metadata setup list, in Project Settings, and drag and drop or copy and paste between them. That works for most of the panes in fact, only Section Types has an import/export routine since setup for that is more complex than just adding new items to a list with their settings intact.

Now if “End” already is in both projects, that shouldn’t be happening, and could be a bug. We’ll have to look into that a bit more closely if so.

I gues it is/appear as a bug. I have removed the “End” metafield, and saved/closed scrivener, then reopen and addede a new ‘End’ field just after ‘Start:’, this doesn’t change anything really.
It seems that this extra field is a blind spot for sync between Scrivener and Aeon. Any changes to the value in either programme will NOT activate the Sync impulse! Whereas If I thange the Start date (by one day) in either programme, the sync is allerted and the new value will show in both programmes.

For your info I use “Text” for both fields, and use the local defenition for dates: 2023-11-29 (yyyy-mm-dd). I tested it also as “Date” but this did not give any sync response at all.

Maybe it’s a missing ‘handshake’ between Scrivener and Aeon? Would be nice if you could find time to check.


Just an extra info.
I will enter the Start date as: “2023-11-25”, and after syncing to Aeon it wil show up as “Sat 2023-11-25”
this has alway been fine with me because that was an indication on whether I had synced or not. The Start and End fields in Aeon are Calendar trimmed.

I cant guess why this should ruin the sync, but now you know.

Fixed… by persistence and… “unexpected” You have to check the Sync settings and set the End to sync to End :-))))
So now it works…
Good to know that even the Sync has worked for me for years, such a small extrafield also needs to be INCLUDED/invited into the process.
Now for a Carlsberg. :beer:


1 Like

All right, thanks for the update. I’ve filed the thread so that it indicates this is something to be aware of with Aeon Timeline, rather than a matter of how Scrivener copies metadata between projects itself, with no other software involved.

Just a few more details:
While copying an item to another project, it persisted that one Custom metadata field would arrive empty, so I added another field below that field and bingo this field kept its information!!!

The only cause for this may be that once when I could not locate the needed fieldname in the sync settings I know I used the “Create New” in Aeon… maybe some parameters from this stayed on in the custom field??? Just a hunch. But after I deleted the field (and added a new one) all is fine and dandy, both while copying from one scrivener project to another, and while syncing with Aeon
I attach a screenshot ( the Danish word for ‘End’ is ‘Slut’) :wink: