Aliases broken

Today upon opening Scrivener a lot of my aliased research files have what appear to be broken aliases, numbering in the 100s, easily. The only thing that I did this week on my Mac is have Spotlight reindex my HD. That’s it, other than switching to a new backup software on my NAS. I didn’t move the files, and they are still where they were before in Finder. Everything was working properly just a couple of days ago. Needless to say, this is a bit of a crisis, as it would be a massive amount of labor to reconnect broken aliases. Help please. (I’m using the most up-to-date version of Scrivener on my Mac. Also, I already tried using a backup versions and reinstalling Scrivener.)

If reverting to a backup doesn’t work, it sounds like a change in the file system and nothing to do with Scrivener itself. Changing anything in the NAS could explain it.

Thank you for responding. I didn’t restore from the NAS. I only performed a new backup to the NAS, as I was having trouble with the Time Machine backup. I didn’t move or touch any of the PDF files on the HD, and I can successfully change the target for a broken alias.

Maybe it’s caused by the change in Dropbox’s local folder location.

No Dropbox is involved.

Something you can try is to select any one of the broken aliases and use the File ▸ Export ▸ Files... menu command. This will export the alias, which you can then inspector in Finder using the File ▸ Get Info... command.

What you are looking for is in the General section of the info window, at the top: “Original”. Copy the full path, and in a Finder window, use Go ▸ Go to Folder..., and paste the path into the dialogue, pressing Return.

Does anything come up?

Thank you so much for responding, Amber.

Okay, I tried what you suggested, and also did some additional testing working directly from the content.pdf aliases and Go to Folder.

One alias I tested that was created on my older computer doesn’t work, and nothing comes up in Go to Folder. Another one created after the move to the new computer works and populates the path in Go to Folder. In terms of what is displayed in the Original field, they look exactly the same with the exception of the name of the actual PDF. If I Select New Original for the broken one, and point to the same path and file the alias then works again.

Any assistance on fixing this issue would be * much * appreciated.

So if I understand correctly, there is a situation where you have migrated to a new computer? One thing I’m aware of with aliases is that they need to be moved together with the original for the best results, in the same Finder “command” (typically drag and drop).

The alias itself is pure Mac technology. We make use of what information it can provided to help keep them pointing to the right spot. The path you accessed in Get Info is the main thing we have available, so if that isn’t complete or correct there isn’t a whole lot Scrivener itself can do to rectify things.

Thank you for responding. I manually rebuilt the project.