An interesting problem with Wine & product registration

I suppose I should have expected something like this, but it’s frustrating nonetheless.

I bought the full version of Scrivener, and I installed the windows version on my Linux machine. It installed fine. I then tried to register it. I put in my name and serial number, and it popped up a message box saying registration was successful… BUT it then said to complete registration it was going to have to connect to some kind of validation service.

Which didn’t work.

I guess I can’t expect Wine to be able to support Scrivener 100%, but man, all through the beta Scrivener ran on wine like a dream, and it still works under wine great – but it won’t register. Le sigh.

Specifically, I get this message:

Activation Failed

Unknown activation error

Product activation for Scrivener failed with error:

I guess my only hope is that garpu knows how to fix this. :smiley:

Sorry, wish I did. It went through for me. Which version of WINE are you using? I used 1.3.32. Does the updater work? I seem to recall others having issues with registration, too. I believe that was fixed with 1.0.1.

That is, I don’t think the problem you’re having is a WINE one, since people on the windows side were having problems registering 1.0.

Edit: here we go:

OK, that’s good to know! I installed 1.0.2… I’ll send in a support request and keep trying. Maybe it was just a server thing.

I’m having the exact same problem. I bought a license for a Scrivener for Windows, and installed it successfully in WINE on Ubuntu 11.04. It works great–except for the eSeller registration. Same activation error code as above. When I e-mailed Literature & Latte about it, the response was to disable my firewall (I don’t have one active, according to sudo ufw status) and/or to replace the eWeb .dll file in the Scrivener folder. I did that, to no avail.

I also updated to Scrivener for Windows 1.0.2, just in case. No help.

As I said, the program still works. It’s just that every time I start it it wants to register. I hit okay, and it verifies that my activation code is legit, but then it cannot connect to the eSeller site. Any help would be appreciated!

Hm. I didn’t have a problem with it. Maybe try setting your router(s) to be DMZ hosts for just long enough to connect? (It should keep working anyway, but yeah, the message would be annoying.)

Have you guys posted on the link I linked to? There were a few other people with the same issue.

Hey garpu -

I read through all the posts on that link you sent, and I saw that one of the posters there had a similar problem to this one. It seemed like there were other registration issues posted there–perhaps unrelated–so I posted to this thread since it seemed specifically about the problem I’m having.

The note about the router here is one I should investigate on my end. I need to make sure my router isn’t running some kind of firewall that’s preventing the program from reaching its server. But that means digging up all that stuff about how to configure my router again. :-/ I’ll try that later tonight. For now, it’s time to write!

Any solution that starts with “turn off your firewall” isn’t a solution. Sorry, but it’s not. If the only way Scrivener can securely guarantee I’ve registered the program is for me to expose myself to a cold and uncaring internet then I guess this isn’t going to be a long-term relationship.

Which is a shame, since I’ve already bought the product.

While the reminder is annoying, you understand that it’ll keep working, regardless, right? As for turning off your firewall for a few seconds and turning it back on, that’s simply the fastest and easiest way to see if the issue you’re having is due to firewall settings (not the only way, but the fastest and easiest). Just like setting your router to DMZ for a few seconds is the fastest and easiest way to see if it’s to do with router settings. Since most of us aren’t having these issues, it seems fairly logical to consider that one of those might be the culprit. You realize that no one is suggesting you turn them off forever, right?

('Course, I’m not sure I understand why online activation at all if it’ll work without it, but I assume that’s an eSellerate thing, and not a Scrivener-specific thing.)

@RobHamm -

Yeah–so far, Scrivener has worked perfectly, despite the reminder to register every time I open it. It’s a minor annoyance, but it hasn’t kept me from using Scrivener every day since I bought it a week ago. As long as it doesn’t prevent me from using the software in any way, fixing the registration issue will remain at the bottom of my to-do list!

But I’m with you–what’s the point of registering it with the eSellerate if the product key allows the program to function perfectly?

Okay, here’s an idea. What if you use a different network? Go to your favorite coffee house and try to register it there. If that works, it’s your network. Something is messed up with your router/firewall settings.

+1 to garpu’s suggestion on trying another network as part of the troubleshooting chain.

For that matter, I know there must be a way to see what port it’s trying to access, to determine whether a hole needs poked in the firewall, or if perhaps a port needs forwarded from the router. I am, alas, not technomancer enough to just know off the top of my head, but it’s something I can look into when I have a few spare cycles. Anyone know what port it needs?

Considering how few of us overall are having this issue, is it possible that it has something to do with the default settings of a particular type of router or something? I’m using a Linksys router (with several port ranges forwarded) and a Pepwave wireless modem (with, of course, those same ports forwarded).

Are you on DSL?

Nope. (Semi)City-wide blanket wi-fi. And I’m using WINE 1.3.32 on Natty 64-bit with Gnome 2 Panels.

Given the small number of users reporting the issue, and that it’s on both WINE and Windows (Product Activation Required), seems like it’d almost have to be a network issue. Especially since one user was able to register it at work, but not at home. If it’s not the firewall or router, could it be an ISP issue? That doesn’t seem likely to me, but then again, a lot of things don’t seem likely to me.

(By the way, I think I thanked you for Walrus long ago, but just in case I didn’t… Thanks. It got me through a couple of years with my old comic before the calendar thing caught up with it, at which point I put a band-aid on the calendar until I switched to Drupal and kind of rolled my own solution–based on the experience of others–with a few contrib mods and a little cut-and-paste-and-pray code-hacking. At the time, I don’t think I truly appreciated the work you put into it–until I tried and failed to make the calendar go on forever.)

Nope, cable. (Comcast, New England, business class.)

… Walrus wasn’t me. Jim Newbury created Walrus. I went from autokeen to autokeen/WordPress hybrid to Drupal.

Well based on this information it sounds like I’m going to have to do some experimentation on different networks…

I didn’t make it to the library today. I’ll try tomorrow. Any ideas for where eSellerate might possibly be blocked? Mickey D’s is walkable, but a bit far. I don’t think the coffee place near me blocks much of anything.

Times like these I miss the huge WAP that was Seattle.

So I managed to disable the firewall on my DSL modem and tried to complete the registration “naked to the world” as it were. No luck. I tried it over wireless and I tried it using a direct ethernet connection to the modem, and both times I got the same error. This is with the firewall turned completely off, so I can’t imagine it’s something on my side of the fence at this point… unless there’s something in Kubuntu itself that’s blocking it.

Well, yesterday I installed the windows 1.0.3 bêta under Wine, and this time the registration worked.