Soon after ponying up $56 dollars (download, CD, taxes) I get Scrivener installed. And what happens? Error message after error message.

RTF Reader Error: Cannot parse RTF file

I’m running Windows 7 with most if not nearly all recent updates. The version of Scrivener I am running is 1.03 and presumably with the latest patches? I just downloaded and installed it a minute ago. I also tried running the program as Administrator. No luck, same error.

Why am annoyed? Because I do this for a living. Troubleshoot computer problems. That’s not to say I’m coming from a mightier-than-thou know-it-all perspective. I’m just annoyed because this is what I do all day, it’s now 9:30 or so and I don’t want to troubleshoot programs, I want to flipping write!


Zamdrift, just to give a vote of confidence, it should work. There are still things to work out in Windows Scrivener, but the issues are much more subtle than whatever you seem to have run into. This is the experience, and I am, like you, pretty experienced beyond Scrivener.

Since you’re a validator, you’ll know. Best to give a little more information for the Moderators when they are next here to answer. A list I think of from what you’ve said:

  • can you write and save in an ordinary manner in a new Scrivener project?

  • could you explain what you are doing when you get this RTF error? It sounds like it may come as you are trying to import a file, but that may not be so.

  • name rank & serial number: you said 1.03 which is latest, and works generally very weil. But on what operating system (XP, V, 7?) and with what basic spec as far as free disk and RAM?

  • probably something else they can want to know that I’m forgetting, but you know the routine, and with the Scrivener team, you are just trying to help them, not getting run through mandatory wheels.

Best fortune, and feeling you should be soon on the air, most probably.


Hi Zamdrift,

Apologies for the inconvenience–I can definitely understand the annoyance, and the desire to be over with troubleshooting for the day. :slight_smile: Lee’s identified the bug here and the fix will be out in the next update. In the meanwhile, the temporary workaround is to rename the “rtfi.exe” file in the Scrivener directory to prevent it from running.

This is not an ultimate solution, because without this running it’s possible to import invalid RTF into Scrivener (such as when bringing in text from other programs like Word or OpenOffice, which can play a little fast and loose with some of the encoding) and doing so could result in Scrivener locking up and crashing. Scrivener auto-saves regularly, but obviously a crash risk is hardly ideal. Working with the tutorial or text directly entered into Scrivener won’t be a problem at all.

Hopefully that at least gets you going with things until the next update. Thank you for your purchase–I hope you enjoy using the program despite this rocky start!

Thank you all.

The bug ended up being how I named my project, which I named: l’Amazone

I suspected the single quote might be the issue, and sure enough when I created a new project called: MyWriting, for example, I didn’t see the error again until I tried opening my previous project.

Now keep in mind that the single quote is a perfectly valid character for a folder or file name on a FAT32/NTFS Windows 7 system. So this isn’t exactly user error. Indeed the folder was created all the same under My DOcuments, called l’Amazone.scriv.

So, this does appear to be a bug, not user error.

I was then able to begin my famous and illustrious career as a playwright, if only for an hour :smiley: