Annoying behavior in 'justify' paragraph mode

To reproduce this:

  1. Set paragraph to ‘justify’
  2. Type [a word] [SPACE] [a word] [:] [SPACE]
  3. Type [SHIFT]+[ENTER]
  4. the two words will be spread over an entire line, i.e. one is at the very beginning and the other at the very end of the line

Once this occurred it is not clear how it can be undone - removing the space after the hyphen has no effect. I suspect this is a bug since its occurrence depends on the last space, amongst other seemingly random factors. Once it is undone, both words stay at the left, independently of what is typed in the first line…

Definitely a bug. I’ve put it on the fix-list!

EDIT: I posted in haste. I’m only getting this when invisibles are turned on in the editor, and toggling them on and off will jump between the buggy behavior and normality. Do you see the problem even when they are off (Format > Options > Hide Invisibles)?

It’s been some time since you posted your question, but as the behaviour I encountered is still the same, let me continue:

Invisibles were off. I just checked again and the problem occurs in the newest beta as well, and it depends on having a [space] after the last word of the broken line or not.

E.g., I write a paragraph, and somewhere in the middle I place the cursor between two words in the middle of a line, after the [space] between the words, and do a line break with [ctrl]+[enter]. Then the remaining words on that line will be spread across the entire width of the line, even if it is just two words.

If I place the cursor before the [space] and then create a lien break, the words are adjusted to the left, and the next line starts with a space.

Hope you can gather what I mean from these words :wink: