Anomaly alert—spaces added between paragraphs after compiling?

Hello. My manuscript looks perfect in Scrivener! When I compile a .docx for Kindle Create, I get these anomalies:

  1. There are spaces added between paragraphs.
  2. There are larger spaces (line break?) added between text files (I have a few for each chapter)

My paragraph spacing is at 0,0—before and after. I’m using MacOS. How do I format so there are no unexpected added spaces after compiling?

Thank you kindly!

I’d have to see the details. We can do a Zoom session, if you want some help figuring it out.

one on one assistance

Watch out for the X times size with font sizes. Counts line spacing in that fill value.

I think what you are seeing is unlikely to be a bug. It would be helpful to know what Compile format you are using, and what file format you are compiling to.

Both of these are probably down to your Compile format settings.

1A: Your compile format can be put in charge of the basic formatting of your body paragraphs. That is, if you are not compiling your docs as-is, the format of the body paragraphs may be being determined by the compile format — giving them a different look than you see in Scriv’s editor. So, in the compile format you are using, body paragraphs may be set to include some space after, for example.

2A: Do check to make sure there are not literal return chars at the end of the text docs after which you are seeing unwanted vertical space.

2B: Compile formats have Separators settings which tell Scriv what it should put between adjacent text docs when compiling. Perhaps your Separators are set to add something you don’t want.

2C: A compile format can also be set to add something to the end of documents assigned to a particular Section Format. Though you would have to have gone in and added something there for this to crop up.

What do you mean by X times size? I’m using Times New Roman font.

Thanks!

Everything is perfect in Scrivener. The following issues persist:

  1. When I compile to .docx, the page breaks work but there is added space (not line breaks) between paragraphs that is not due to formatting.
  2. When I compile the same document to an .epub, there is no added space between paragraphs but I cannot get any form of page break to work.

I’m looking for a solution to either 1 or 2. Thanks a million. Here are what the mysterious spaces look like:

It is due to formatting (almost certainly), but there are multiple layers of formatting to inspect in order to find the issue.

eBooks don’t have pages, so you need section breaks, not page breaks. Again, there are multiple possible sources of the problem. I don’t think this or any other text format is an efficient way to troubleshoot.

We can do a Zoom session, if you want some help figuring everything out.

one on one assistance

  1. Are those first line indents on your paragraphs produced by formatting or by you typing tab characters?

  2. Also, what Compile format you are using for the compile to docx? (Is it one you have custom modified or it is an off the shelf Scriv provided compile format?

gr—thank you greatly for helping me.

  1. The indents are produced by formatting. I used Paragraph Indents > First line .5 ins
  2. I tried many Scriv formats as well as my own to no avail. I’ve tweaked page breaks in other formats Changing fonts didn’t help.

My goal is to publish on Amazon KDP. What settings should I use to compile a .docx in Scrivener to open in Kindle Create (only opens .docx) correctly? From Create I will export a .kpf to KDP.

My current workaround is Compile to .epub > convert to .docx for Kindle Create > Export to .kpf.

Might some of the formatting issues be coming from all of the layers of conversion going on here?

It’s worth noting you can just upload ePub straight to KDP, which seems to work fine for most people. There isn’t a need to convert that to DOCX, import that into another tool, and then use that tool to create another kind of file, and then upload that.

But if that is what you must do for some other reason I’m not thinking of, I would start by compiling to DOCX in Scrivener, rather than ePub, and at least eliminate whatever tool you are using to convert from ePub.

But that is the path that is giving the OP trouble — some unexpected paragraph space-after getting into the mix.

Ah okay, I see I missed that from the first post—well I don’t see any indication that the formatting from the DOCX has been verified in something other than Kindle Create.

I.e. for all we know this is a bug, or “helpful” feature, in Create. That could be verified with an extremely simple test: drag the compiled .docx back into the binder. If it looks fine there then one should broaden their research beyond Scrivener as it is very likely nothing they do in Scrivener is going to make it better.

Either way my point still likely stands: one does not need to use Create as far as I know. That’s a tool for people that don’t have tools like Scrivener that can create high quality ePubs, from what I’ve seen of it—but I’ll freely admit I took one brief look at a few years ago and didn’t see anything in it worth the download.

1 Like

Correct! Thank you I’ll upload direct.