Any way to improve font rendering on screen ( coming from macOS )

I use Scrivener 3 on macOS and the readability of the fonts in my novel are great, sharp yet smooth. The same novel when loaded in Scrivener 3 on Windows are very difficult to look at, sharp but ragged, they cause a bit of eye strain. I tried both under dark mode and light mode ( I tend to work in dark mode all the time ).
Anyone have any thoughts on how to improve this? I tried Windows 11’s font smoothing on and off ( defaults to on ) and it made no difference.

image

Vincent, thanks for the tip! Sadly, I tried with Display Font Hinting at Default, No Hinting, and Full Hinting. This seemed to mostly vary the glyph positioning, and not help with the actual visual rendering quality of each character beyond some characters like “w” were rendered slightly better. It is jarring to see the visual layout of the characters and lines shift so much once No Hinting was enabled.

What has helped me though I don’t think it is a great solution is putting my view size to 150%, will have to see if this is sustainable.

Either way, thanks for the help Vincent!

1 Like

I suppose it is (close to) pointless to ask if you have the same issue in some other text editing software? Say, LibreOffice?

Word documents tend to also look not great under Windows, as compared to macOS Word. What is surprising is that Windows 11 font rendering in some of the interface is well done, bringing it a bit closer to that of macOS. Unsure if Word or Scrivener are or even can hook into whatever Windows 11 is doing in some of its own interfaces.

How about screen resolution ?
Not to point at a possibly low quality video adapter.

Could you upload a screenshot. (It’d be funny if what is “bad” for you is actually what we windows users are used to… )

. . . . . . . . .

My screen resolution is 3440x1440. I verified that I am indeed using ClearType.

It may just be that it is just how it is on Windows, though again I feel in Windows 11 Microsoft has done something to make their UIs look better (at least the OS level UIs).

I may just be in a spot of just having to ignore it the best I can :wink:

Well… Did you check your monitor’s internal settings ?
(If not using the same for both Mac and PC computer, that is.)
Else: I don’t know. But perhaps someone else will. :wink:

Same monitor with both the Mac and PC. I think I am just facing the reality of font display on Windows is not as good looking.

1 Like

As a dual user of Windows and Mac, I can attest to Windows font rendering being really nasty.

Have you tried the software MacType? It renders fonts on Windows similarly to how they’re rendered on a Mac or a Linux - can’t go back to not using it now!

3 Likes

Okay, in that case I respectfully request that none of you Mac users upload any screenshots of your beautiful font rendering, as I don’t want to know what I’m missing. :nerd_face: :metal:

Best,
Jim

4 Likes

Hey. I just did.
Result:

  • no noticeable difference.
  • Service mode: computer rendered unusable.
  • Manual mode: “Scrivener can’t connect to license server”.

What did I do wrong ?

(Countdown to uninstall initiated)

@rachc659 funny you mention MacType, I was thinking about looking into it. The downside is that the installation seems a bit of a trainwreck, and that anti-virus software seems to get false positives because of it.
In your experience of using MacType, does it actually make a visual difference? I would love to have the macOS system font so that the Scrivener application’s UI font looked reasonable.

@Vincent_Vincent oh wow, that is disturbing to say the least!

If there was a difference in the font (and it is really hard to tell - could be psycho-something-somatic; like I wanted it to work, so my brain looked for the candy) it looked as if the app made the font a tiny bit bold. Like it rounded up the vector, and widen the font just a tad, adding its outside vectoral-outline to it. (Like an overlay.)

But I was only able to get to that point using manual-mode, before Scrivener telling me it couldn’t connect to the license server. Else, I had no control whatsoever on Scrivener (couldn’t select any binder doc etc).
(Had to shut everything down, restart scrivener without the app interacting, load a project/document with enough text to give me an idea of the potential result, and then restart Scrivener through the app this time. All this so that my selected doc would be in the editor upon opening the project.)

Have you tried to turn it off? Sub-pixel rendering isn’t that needed with the smaller pixels of modern hi-res displays anymore.

I’m not sure, but I think Windows uses grayscale edge pixels when it’s off?

Another thing worth trying is using a different font. There are some out there that are optimised for Windows’ bad rendering. 20 years ago I would have suggested trying a fixed-size bitmap font, but I don’t know if there are modern ones that have resolutions useful on a 4k display.

Yea I turned it off, it made no real visual difference sadly.

I think I am going to do some more research into MacType, as I have heard a few people mention to it to me now. Hopefully with less issues than @Vincent_Vincent had!

I will report back with my findings.

Out of curiosity, I just tried turning it off too.
Then ran the mandatory screen tuning selections that comes with changing the setting.
It actually did something on my end: all italics where barely readable afterwards. No matter the font.
This looks more and more like a rabbit hole to me. I’ll stick to windows’ cheap graphics :stuck_out_tongue: (I had no issue whatsoever with it until recently :slight_smile: )

I find it hard to believe that there could be a simple app that would make Windows’ fonts look better without our dear friends at Microsoft implementing it…

So I have done the following to help improve my UI readability.

I found a non-commercial SF Pro OTF font that is the same as the system default font from macOS. Setting all of the Scrivener UI fonts to this at size 12 regular has made a HUGE improvement visually.

I have also installed MacType (latest RC1 version). In a word it is a bit finicky to be sure.
I am currently using the MacTray workflow and am using a setting called: “XHEi iOS, OSX”.
Some apps don’t see to be able to work with it while others do. There is probably a way around this, but not too worried at the moment.
Overall, this is an improvement visually and I can “almost” be convinced that I am on my Mac.

1 Like

I have since moved back to the MacTYpe “Default” profile. I also added the following to the [UnloadDll] section of the MacType.ini, so that these programs wouldn’t be affected. You can add programs to ignore at the end of the [UnloadDll] section like this:

; my custom additions
iTunes.exe
XIVLauncher.exe
ffxivboot.exe
ffxivlauncher.exe
ffxivupdater.exe
ffxiv_dx11.exe

MacType was wrecking the iTunes interface (which is already not great looking on Windows).

Not sure If will be in for MacType long term, will post my longer-term findings later on.

2 Likes