Any way to make Scrivener add a blank line after all the paragraphs in my novel?

I’m trying to copy over a novel I’ve written in Scrivener to Wattpad.

On Wattpad, it’s best to have a space after every line. In Scrivener, I haven’t done this at all while I was writing the novel.

Is there a way to select a body of text in scrivener and then tell it to add a blank line after every paragraph? Or do I have to do it manually?

Thanks.

  • Hayden.

If you can truly have a new line after every paragraph marker (don’t forget about lists and such!), then you might look at compiling your documents, using the Replacements section of the compile window to replace a single new line with two. I think the way you do that in version 1 for Windows is to make Scrivener “show invisibles”, and then copy a single paragraph marker into the “Replace” column, and paste 2 of them into the “With” column. You won’t be able to see them in that pane, but compiling will result in two paragraph markers for every one that was in your original text.

I don’t know if you’re still checking this but I KNOW YOUR PAIN. I don’t recommend the find+replace single enter for double option, because if you export your file to any site that naturally does add lines after paragraphs (like, say, Ao3’s rich text editor), your whole fic now has two blank lines between each paragraph and that’s just a lot of white space. That was… a fun bit of line removal, when I discovered this.

My solution: go to the editor, and then to the line spacing dropdown. (It’s directly to the right of the font size dropdown.) It’ll give you 1.0x, 1.5x, 2.0x, etcetera, and at the bottom, “More…” It’ll give you options to set indent and spacing defaults, approximately as follows:

Go to “After” and set it to the same size as your font size; it’s 12pt font for me. That’ll get the editor to treat blank lines after paragraphs as the default, and will keep the blanks there when exported too. To get it to work on already-written text, make sure to select the text first. For the whole novel, you’ll probably want to select the whole draft folder in scrivenings mode and ctrl+A.

Nice one! Thanks for the idea. I definitely have a use for this as a quick & dirty fix.

Just wanted to point out that rdale was not suggesting find+replace in the editor, but rather using the compiler’s Replacement capability. So the text in the editor remains unchanged using his method.

You may already know this, but mentioning it in case you didn’t catch that part. :slight_smile:

Best,
Jim

Maybe I’m doing it wrong, but following those instructions makes it look like there’s a space after paragraphs, which is good, but there isn’t actually a space. I tried copying and pasting into Wattpad, and it didn’t give me spaces there.

I tried this, but it won’t let me even select the paragraph symbols to copy them.

All you have to do is start after the last character on one paragraph, and then SHIFT-right-arrow once. Then CTRL-c to copy it, bring up the Compile window and paste into the Replacements pane.

Hi

I’ve tried the replace in Compile and it doesn’t seem to work for me…but as I can’t see the character I’m replacing or the two version of that in the ‘replace with’ box I’m not sure…

How do I make these characters visible?

Also
I’d like to override the indented first line in the paragraphs in a compile - but can’t find a way to do this.

I’m not sure if this is the same menu in version 1 of Scrivener for Windows, but on the Mac (and v3 beta for Windows I think), the menu is View->Text Editing->Show Invisibles. Once you’ve selected and copied that character, you can verify that you have it in your copy buffer by using CTRL-v to paste it into your text, observing that you get new blank lines where there weren’t any before.

Then you can go to the replacements tab and paste it there.

Hi

Thanks - I got it to work and now have a blank line between paragraphs.

I’ll post about the paragraph first line indent as a separate thread.