Apostrophe problem introduced into Word compile

I’ve completed my 132,000 word novel using the Cochin font. When I compiled it to Word to send to my editor I did so in Times New Roman. I have no problem with apostrophes in Scrivener, but now that I’m working on my editor’s comments in Word (through track changes) when I try to add a new apostrophe, Word’s Autoformat function adds a space after the apostrophe. Somehow the Word doc was created with the instruction to do this when I compiled it. None of the original apostrophes have spaces in the document, it only happens when I now add a new one.

This doesn’t happen to the same doc in Scrivener, and it doesn’t happen to any of my other docs in Word.

I can’t go back to the Scrivener document now because I have to work with Track Changes now on my editor’s comments, but I’d sure like to know how I created this mess so I won’t do it again. I’d also like to know how to fix the Word doc now, but I guess that’s not a question for this forum.

I’m not sure, that isn’t something I have any experience with. I mean, I’ve never seen Word add a space after an apostrophe like that. Is it an actual space, as in what you get when you hit the spacebar?

To what format did you compile by the way, just regular RTF?

Thanks for your response, Amber. Now that I’ve had more time to deal with it, I know a little more about it, but I still have no solution.

It’s not a “real” space. What is happening is that Word is creating my “smart” punctuation - both apostrophes and quotation marks - in Helvetica font and it “appears” as though there is a space on the outside of the smart punctuation. So the space appears before open quotes and after closed quotes. However, if I highlight it and change the font back to Times New Roman, the “space” disappears. Somehow in the instructions for how to auto format smart punctuation, Scrivener tweaked Word to tell it to change the font to Helvetica. I wrote the book in Cochin and compiled in New Times Roman.

This does not happen when I write in this file in Scrivener, but I do see the straight quotes change to curly quotes. In Word, this only happens to newly typed quotes, not to the existing text, and it only happens when I export to .docX format from this particular file. It doesn’t happen on any of my other files in Word, but it does happen on my editor’s computer and on another friend’s computer. This is embedded in the style of this particular file.

I cannot solve this by going back and compiling in a different format or font because I am now working in Word with my editor, and we have this 500 page novel with all his Track Changes remarks in it.

If I could just go back to figuring out what Scrivener did during the compile process to the Word file to change the instructions for how to make smart punctuation, maybe I could figure out how to undo it in Word.

Unfortunately it doesn’t appear to be as simple as font and format settings. I ran a test using the conditions you describe, of taking some sample text in Cochin, then compiling with conversion to TNR 12pt, using the docx converter. I then opened this in Office 2010 of PC, and all existing punctuation is in TNR, as well as any new punctuation typed into Word. Maybe you’re both using a different version of Word?

One thing to try is select a range of text in the .docx and manually change the font in Word to TNR, then see if there are any problems within that span of text. Maybe Helvetica is sneaking in the cracks and doing a wide reset will get rid of it.

Yes, I realise that, I was just meaning to try that in a diagnostic sense as it might help us figure out what went wrong and perhaps even how to fix it for the future.