Applying Metadata & Editing Default Style

Man, I love this program! After using it for several months (v. 1.11) I have only found two things I wish it would let me do. (I searched the forums and didn’t find them; please forgive me if I’m duplicating anyone else’s Wish List or missed a Tech Support posting.)

  1. I wish I could apply Label and Status metadata to multiple items simultaneously. If there’s a way to do this now, I haven’t found it.

  2. I am working on a long, ongoing project for which I have developed a specific ms style that I want to apply to all of my many, many new documents. I would like to be able to edit the Default style more fully (line spacing, indents, font size etc., beyond what’s now available in the Preferences dialogs, so that I don’t have to keep setting my style to every new blank document. I want those new docs to just come up the way I want them. Again, if there’s a current way to do this I have not yet found it.

From the FAQ:

As for your second issue, I’m not sure what you mean by more fully, since the three things you mention all can be set up in preferences. In the Editing section, just set things up using the ruler, the way you ordinarily would. All new documents will use these line-spacing, indent, margin, paragraph spacing, font family & type, and font size settings. There really isn’t much else that the OS X text engine can do (I think some of the special font attributes, like shadow and such do not work).

Well, heck :confused: . Guess I didn’t drill deep enough on that metadata thing. I’ll have to explore the styles, though, because I can’t seem to make Default look the same as my created ms style.

Thank you for your reply, and for not embar :blush: rassing me.

Re editing the default style: wWhat I want to do is set a first-line indent and 1.5 line spacing in addition to selecting a font/size/style. The Default is no indent and single space. I realize that this is a ruler thing (thanks for the FAQ) and as such may be a problem, but what I want is for Scrivener to apply these attributes to all new documents. So I guess my Wish List item is for, in addition to the “Revert to Defaults” button, you add a “Save as Defaults” button, which would override the program’s default ruler settings in addition to the attributes I can manipulate. Seems as though it should be possible; you had to initially set the ruler attributes for Default. Or is this a coding thing us nonprogrammers don’t get to play with?

No, simply set the ruler in the “Text Editing” pane of the preferences, adjusting the indent to how you want it and the tabs – you do that by dragging the T-bar that you see at the right margin mark to the point where you want the first line indent to be, and just pull any tabs down off the ruler; choose 1.5 from the spacing drop-down button, set your fonts and anything else … then, above all, don’t forget to click the “Apply” button at the bottom before exiting – if you like, that is your “Save as Default” button. All your new documents should open with that as default, and for any earlier ones, just use the “Documents: Convert: Formatting to Default Text Style”.

You should be there …



Thanks to Mark and Amber for clearing this one up. As Mark says, just use the ruler in the Preferences to set up your default style, just as you would in the main window, and be sure to hit Apply (important) - everything you want to do is already possible.

Thanks for your kind words about Scrivener!

All the best,

Ok then, here’s what’s weird. I did exactly that, and it didn’t work the first two times I tried to apply it (before I wrote to you initially), and then it did work the third time – which is, I suppose, the charm, as they say – after I read your posts. The first two times the app reverted to the “no indent, single space” Default, which is partly why I didn’t think there was a built-in way to do what I wanted. But now it seems to work. Did I discover an intermittent bug, or does my computer think it knows more about what I want than I do? (Wouldn’t be the first time . . . )

Thank you for the replies to my post, which I suppose no longer belongs in the Wish List forum, but should now be labeled Tech Support?

I’m guessing that you may not have hit “Apply” the first two times, although you may not have realised it. Most Preference panes on OS X don’t ask you to hit the “Apply” button, so you most likely wouldn’t be used to having to take this step - most preferences get updated immediately (and indeed, I have altered 2.0’s preferences to do exactly this and got rid of the “Apply” button, as you wouldn’t be the first to miss it having got used to the more usual way of doing things on OS X).

Anyway, glad you got it working.
All the best,

Well then, one more reason to look forward to the upgrade. Thanks for the help, everyone!