architecture problem when trying to install


I thought I should try the linux distribution before I run out of trial time to run it on my windows desktop. my netbook is what i take with me when I want to get out of my apartment and work in a different environment, and so there’s no sense relying on scrivener if I can’t take it with me.

but when I tried to install the packages I got a message saying that it was the wrong architecture. I assume that’s because I am running 64 bit #! linux and scrivener is written in 32.

I am not married to crunchbang. I just switched to it because ubuntu started drowning in molasses soon after they got to 12 on my machine, so I got mad at it and decided to try something else. I’m willing to try something else again if that’s what it takes to get scrivener going.

I’m a noob but prefer installing things using terminal, as the unity OS turned me away from trying to install things using a software center or the like. it just seems easier and more effective to dutifully transcribe a command line.

I should always look around more. so the problem is that i’m using 64 bit linux but scrivener for linux is written for 32 bit?

okay, fine. i’ll install a 32 bit linux os.

The only thing I use my netbook for is writing and using the internet, so I’ll try this and see if it works.

well I asked some crunchbang people and the got me to install 32-bit libraries very easily, so I have the program installed, but I can’t figure out how to make it run? is there a command line I can use to get te executable to execute?

In terminal, check to see that Scrivener intalled in /usr/bin
You can type which scrivener and it should return usr/bin/scrivener
Then just type scrivener , hit return, and it should start.

oh, indeed it should. but what actually happens is this:

in response to “which scrivener”

I do get usr/bin/scrivener

but when i type “scrivener”

i get “/usr/share/scrivener/bin/ 36: exec: /usr/share/scrivener/bin/Scrivener: not found”

and yeah i expect I have a problem here

Hi Oenanthe, ever get this up and running? I have to install the 32 bit libraries as well, I’ll look on crunchbang to find it out, but I suspect that the scripts are installing everything in the wrong place and that’s why it isn’t running correctly. (Did you use the archive manager?)

If I figure it out or get help on it I’ll post. Kim

Hi again, Oenanthe,

I might still have problems with my 32 bit libraries on my 64bit T530, so I installed Scrivener on my T42, which is 32bit, without any trouble (also running the latest CrunchBang).

After re-reading your posts, I suspect that you’ve installed it incorrectly by maybe using the archive manager? Just a guess, but I did the following to get it to run under CrunchBang on my T42:

After downloading the .deb package, it ends up in the downloads directory, of course. Just open up a File Manager and right click on the beta package. At the top you will see the “Open with GDebi package installer”. Use that to install and it should be fine if your libraries are okay (32 bit, which you said you installed without a problem. I had an error message about a dependency, so I haven’t tried Scrivener on my 64bit, yet–wanted to check with the gang on CrunchBang before I installed Scrivener.)

You should be able to just bring up “Run Program” and type scrivener to get it running. Kim

Hi titianmom,

I tried to re-install but i still have the same problem, it’s not running.

and I have a very complicated problem in that I can’t seem to create a bootable USB that doesn’t hang immediately on boot, so I can’t change to a 32 bit linux (which i would happily do) and then install scrivener on a 32 bit os.

(the problem I’m having with trying to boot a live cd on usb install is that it hangs near immediattely on a black screen and the message "“SYSLINUX 4.06 EDD 4.06-pre7 Copyright © 1994-2012 H. Peter Anvin et al” and it doesn’t matter which os I try, it does that.)

Oenanthe, I’d go to CrunchBang forums and ask about the USB situation. I never use USB for installs. I downloaded the torrent, then used Xfburn to change the .iso to an installable file and put it on a 4.7GB blank DVD. They’re $6.50 at Wallmart for a pk of 10. :slight_smile:

Do you have a DVD optical drive?

Again, I’d ask the folks on CrunchBang about the USB if you haven’t already. They could prob help you out.


Oh, and FYI, found out that we don’t need to install ia32-libs at all. That was a transition until they got to true multiarch.

Now you only have to:

sudo dpkg --add-architecture i386 sudo apt-get update

I went back and removed ia32-libs entirely and redid the arch, but I’m still getting the same error. I posted my problem in another thread.


Hi titianmom;

the computer i’m using is a netbook and it doesnt have any disk drives at all. I’m stuck doing it from usb. I think.