Arrow keys sometimes opening menu at random

Hello. When I’m pressing the arrow keys to navigate in text, sometimes - at total random - Scrivener will open the File menu. I don’t know why or what’s going on, but it’s really annoying. It’s a new computer, so I don’t know if it’s that, but can anyone tell me how to stop this? I can’t tell what the pattern is. It will be fine for a bit, but then I’ll press the up or down key and suddenly I’m I the File menu for no reason.

Windows 10 Pro
Latest version of Scrivener.
ThinkPad Carbon v4

The issue is not the arrow keys, but rather your ALT key.
A quick ALT (+nothing) leaves the menus waiting for keyboard navigation. (You can tell by the menus having an underlined letter.) The arrows then do effectively pop-open the file menu.

This never happened to me (I had to mess with it to come up to this conclusion), so either be mindful of where your fingers go, or see if there is a Windows setting causing this, by any chance. (Although, now that I think of it, should it be a Windows setting you’d get that every time.)

1 Like

Thanks a lot. I was thinking maybe another key was stuck down or something. Is there any way to disable this without disabling alt? I swear I’m not touching it. I just want to write but this is really infuriating.

This, perhaps (I did not read it)

If you can’t find a local solution, you could hijack the alt key using AutoHotKey, designing a script that would key-up/reset Alt – then type in the arrow – when you type an arrow.

This goes so fast that you wouldn’t even feel it.

Downside: you wouldn’t be able to navigate the menus using Alt and arrows anymore, unless you first disable the AHK script.

Thank you. I’ll try auto hot keys. I really don’t want that shortcut, and I’m just glad there’s a way.

1 Like

A simpler way to go about it would be to press ESC before using the arrows.

Otherwise, just design a script that goes: Arrow → ESC then arrow.