Assign compile level to document in binder

Scrivener organizes documents in a hierarchy of levels. A document “within” another document is on a lower level (higher level number). When you compile, in the Formatting section of the compile dialog you can style all documents that belong to a certain level.

For my current project I use the APA template, where I have created three documents “within” or “under” the Introduction (see the attached image to better understand this and the following questions). What I don’t understand is this:

  1. Why does the Method document, which resides on the second level below the Main Content folder belong to Level 1+ and not to Level 2, like the Results and Discussion?

  2. Why does the title of the Main Content folder not appear in the compiled document?

  3. How can I assign the three new subdocuments, Trust, Sharing, and Hypotheses, to Level 3?

I am completely confused and would be happy about an explanation or a link to one.

You have chosen to define yourself what to include in the compile, so it would help to see what you have checked in Inhalt to be included.

As preset in the APA template, everything is included in compile.
Bildschirmfoto 2016-07-15 um 12.26.11.png

A guess, after experimenting a bit with the text I myself am working with – It is logical if you look at it bottom-up instead of top-down. The difference is between documents that are folders or not, or that contain children documents or not. Test what happens if you have a more strict structure, using only folders at a given level and always have the text documents at the lowest level.

Please also note the icons in the binder. “Method” and “Introduction” are represented by stacks of paper, rather than by an icon that looks like a single sheet of paper. So in the Formatting section of compile, you have to work with the rows that have a “stack of pages” icon, rather than the “single page” icon. Create a “level 2” of that row, and then you can make those documents compile differently from Level 1.

This is an aspect of compile that I’ve never liked; you can change any document (or stack) into a folder, thus allowing you to set compile settings based on that row of Formatting, but you can’t control which document icon is assigned unless you refrain from indenting other documents under it (or always indent documents under other documents). If you want a document with sub-documents (I’ll call it a “stack” for brevity) to be formatted the same as document with no subdocuments (aka: a “page”) of the same level, then you have to have duplicate Compile Formatting rows for both “stacks” and single “pages”.

One handy thing about the Formatting pane is that you can select a row in the Formatting section of compile, hit CMD-C to copy all the compile settings for that row. Then select another row and hit CMD-p to paste those compile settings. So just create as many levels for the “stacks” as there are for the “pages” and use that technique to make the formatting the same for both kinds of document. That’s what I’ve done, and it works okay, except when I fiddle with the compile settings for one set of documents; I have to remember to copy and paste the settings to the other kind.