While in Screenplay Mode, when I begin typing Dialog, the first sentence is not automatically capitalized. It does work for any following sentence within that section of dialog. Is this a bug?


Ah. This is because it bases capital letters on punctuation, and of course, there is no punctuation at the end of the character line…
Will add it to the list of things to look into.

I just discovered this is the same for the Action paragraph. There is no auto-capitalize on the first sentence, but any following sentences work fine. I suppose for the same reason you’ve stated … no punctuation at the end of the Scene Heading line.

Yes, exactly. Like I say, it’s on my list to look into for 1.01. It’s quite complicated, though, as the whole auto-capitalisation routine is pretty involved.

Thanks for fixing this! :stuck_out_tongue:

It is now almost perfect. :wink:

A tiny niggle: the current routine capitalises parentheticals if they consist of more than one word. In a perfect world, it really shouldn’t. Parentheticals are usually all lower case.

Also, the capitalisation routine seems to be English-centric. E.g. it capitalises the word “i” regardless of the document’s language settings. Don’t know if that’s fixable…

Have just completed a first draft in Scrivener, and it’s been a joy! The tweaks to screenplay mode in 1.01 made a huge difference.

These quibbles - whilst well-founded - are unlikely to be addressed in the near future, I am afraid. I had to program the whole auto-caps routine myself, so my advice to non-English customers would be to turn it off, as I have no idea about the conventions for other languages and am unlikely ever to code it. Sorry. :frowning: Likewise, in screenplay mode, this is why there is a separate preference under the Preferences for enabling auto-caps in this mode. I would think that generally you would want to disable it because of exactly this sort of annoyance - the auto-caps is very generalised and knows nothing of screen-writing modes etc.
All the best,