Auto complete, part II

I’m using the NaNoWriMo trial version, and cannot figure out how to get Auto Complete to work.

I’m used to Word & Pages, where the words automatically complete as I start to type them. I’ve got a character name with an special character in his name ('Vão, short for Estevão, from Portuguese), and while the name’s added into the auto-complete list, Scrivener will not auto-complete it. It’s a pain in the butt to have to either insert a special character each time I type his name, or to copy/paste from a prior use each time I need to use it.

I did a search in the forum, and turned up the “hit cmd-. or opt-esc” thing, but those don’t work, either – nothing happens. There’s nothing in the help docs that I can find that tell me how to turn on auto-complete, either, or even how to use the feature. What am I doing wrong?

How does this work in Pages? I thought Pages worked the same to be honest. Scrivener uses the OS X text system, so auto-complete works the same as in Mail, TextEdit, Safari etc.

You do indeed hit opt-Escape (or just Escape on its own), or cmd-period. But you have to start typing the word first. Your particular example starts with an apostrophe, though, and I think that causes problems. You may need to enter it as Vão, and enter the apostrophe and V yourself before calling auto-complete.

All the best,

Sorry, my brain farted there. I meant only Word; Pages I’m still getting used to, having recently converted to it and still working with it.

sigh from what you describe, it’ll be faster & simpler to just type the name without the tilde and go back and do find/replace later.