Auto-complete stopped working...

I changed some text formatting presets, and now the auto complete list isn’t working. The words are all still in the list, but they’re not completing automatically as i type anymore. How do I get this feature to start working again? Thanks

Formatting presets should not be having any impact on the auto-complete lists—unless you mean that you were messing with the script settings. There are some checkboxes in there that could impact auto-complete, not to mention scoping.

But first, to sanity check, you have the right checkboxes set in the Corrections preference pane?

Hi – I’m having a similar problem. I’ve been using auto-completion in the screenplay mode for a year or more, and all of a sudden, it’s stopped working. When I type in the first few letters of a character name (for example) I can see the selection I want to make (i.e. the auto-complete gives me the standard completions, and also my personal selections, character names, locations, etc.), I can arrow up or down the selection pane to the correct name or term (highlighted in blue), and then when I press “return” for the completion to happen…nothing. The selection menu disappears and I’m back in my script (albeit one line down, apparently because I pressed the ‘enter’ button). After some time of irritation with this, I then tried monkeying around in the ‘script settings’ section and have probably mucked it up now. Help?

I’m not so sure if this is the same problem. The original poster indicated that the feature isn’t calling up a recommendation list at all, whereas it sounds like you get the list, but it isn’t do anything when you use it. If so I’ll split this thread.

As for what you’re seeing, what happens if you use the mouse?

I use a laptop, so I don’t have a mouse. I’ve tried hitting a number of possible alternatives to “return” (the touch-pad of my laptop both hard ‘click’ and tap controls, shift, control, option, command, etc.) just to see if I’m missing something obvious. Thanks for any help; I feel most dunce-like for not being able to muddle my way through.

Surely it has some kind of built-in pointing device, however? A trackpad most likely, below the keyboard, where you can move the pointer around and click as though using a mouse?

I’m mainly curious to see if the problem is with input or with the mechanism. If the “mouse” works, then it would be evidence that there is something wrong with the arrow/enter mechanism and we could approach the problem from that angle.

Yes, sorry – when I use the track pad to control the arrow, I can hover the arrow above the correct (and highlighted) selection, click, and nothing happens. The selection stays exactly as though I’d clicked nothing. When I tap my finger (my trackpad is set to accept a tap as an ‘enter’), the selection pane disappears and I’m returned to the regular Scrivener screen, alas. Does that make sense? I’m not having any trackpad issues in any other application/program.

Okay, thanks for verifying that. What happens if you try completion on a normal word, not in your auto-complete list? For example, type in ‘Burl’, and then tap Opt-Esc. Can you interact with that list?

I tried typing “burl” as part of “action” text and as part of “character” text, just to see if there was a difference (no difference in outcome). As I typed “b”, my personalized “b” options came up (character names, “bathroom”, for example). As I completed the rest of the “u-r-l” those options disappeared. By the time I’d finished typing “burl” I had no suggested completion options. With the cursor blinking at the end of the “burl”, I typed option-esc. Nothing.

Hmm, you should have seen a word list from the full dictionary when pressing Opt-Esc, you could try the menu command, Edit/Complete manually, that shortcut can be different on some systems. What version of the operating system are you using?

Version 2.0.1. I tried typing in the name of a character (in the character text mode), got the completion list, scrolled to highlight the name I wanted completed, went to edit>complete and upon selecting that option, the highlighted selection returned to the one at the top of the list (which wasn’t the one that I wanted, just the first one that started with the same letter), and…that was it. Is there a newer version of Scrivener I ought to be trying? sigh

Oh, yeah that’s an extremely old version! The latest is 2.3.1. Please go to the main home page (click the book and coffee icon above) and download from the link in the top-right.

Oh, look. And everything is fixed. headdesk

Thanks for your patience. I truly appreciate it. I love Scrivener, and I don’t know why it didn’t occur to me to see if I was up to date.

That’s the kind of bug fix we all like around here. :slight_smile: You’re welcome.