Auto-correction substitution - curious behavior

Yeah, it’s me again. Hope my screen name isn’t causing people to cringe.

I’ve been making use of the auto-correction substitutions feature lately but ran into a curiosity. Having typed literally hundreds of large technical documents for engineering firms over the last decade I’d gotten a little sloppy in my first-draft typing in order to get thoughts down. The company used Word and I’d set it to make up for some bad typing shortcuts I’d established (for instance “id,” “im,” “dont,” “wont,” “hes,” etcetera).

Here’s the curiosity: after I edited the substitutions and set Scrivener to automatically fix the incomplete words, it got overly aggressive. It took me a few minutes and some tests to see what it was doing. When I typed “didnt” it corrected it to “dI’dnt.” When I typed “identify” the corrected word was “I’dentify.” Typing “imagine” gave me “I’magine.” Typing “hesteria” gave me “he’steria.” (edit: I also had added “cant” but just removed it after I noticed auto-correct created the word “significan’t.”) The pattern became clear, auto-correct substitutions was finding the to-be-corrected-words even when they were contained within other words (see above examples). After the change, it then marks the word as misspelled.

The fix was to turn those particular word substitutions off. I did try to enter the misspelled words into the substitutions list using a space in front and after (thereby thinking the substitution match criteria might require the spaces) but it did not work.

This machine has 1.0.3 installed running on Windows 7.

Anybody else getting this? Or am I just witnessing the proper behavior from a super aggressive auto-correction feature?

Thanks for any help! :slight_smile:

At least one other person has reported this; it’s not just you. :slight_smile: The substitutions are pretty literal in that sense, so you can get around it (somewhat) by using the spaces–for instance you could replace " id " with " I’d " and that should work, although there are probably occasional places where you wouldn’t have a space after the word (due to some other punctuation) so the substitution wouldn’t happen there, etc. I have this on the list for Lee to take a look at, so we’ll have to see what he’s able to do.

Okay, thanks MM for the response. Just as an fyi for Lee, I did try adding a space before and after the subject words and it did not affect the behavior, meaning the list didn’t seem to recognize the spaces as part of the substitution’s search criteria.

You’ve probbly seen the related post (it might be the other person you said you were aware of) [url]] but I will report and link to your response that you provided here.

Thanks again! :smiley:

Hm, when I tried with the space (in 1.0.3) this did work for me–could you give a specific instance of what you set up and what happened when you used it? As I said in my previous post, setting up a replacement for " id " (space before and after) to become " I’d " prevented the replacement in the middle of words; it won’t however work for cases where some punctuation immediately precedes or follows the “id”, so it’s not ideal, I agree.

I have seen the other post; that wasn’t the user I was referring to, but I appreciate your help in getting to the bottom of that as it appears that ultimately the issue is the same. :slight_smile:

MM, my sincere apologies (and to anyone else that I may have unintentionally misled) :frowning:, I just retried your space before and after suggestion and, to my astonishment, it worked.

It was one of the first things I tried after originally figuring out what was going on. (I even mention in my original post in this topic having tried the spaces method to no avail.) In any event, I must have done something wrong because putting a space before and after does work for me.

I will comment likewise on the other topic I was posting under to clear up any potential confusion. :smiley: