Auto formatting text?

As an author, there’s one thing that drives me crazy while writing a script. Here’s an example of a character asking a question in a manuscript:

“Did you eat my lunch?” asked Joe.

Notice that “asked” is NOT capitalized – nor should it be. But Scrivener will always capitalize it, so I have manually fix it each time.

Is there some way to make this automatic?

I’m not sure what setting could cause your issue, but here are my Scrivener and System preferences for reference.

[attachment=0]Screen Shot 2021-02-16 at 14.21.03.png[/attachment]

Ah! It was auto cap in keyboard. THANK YOU!

You had a problem because “capitalize words was” wasn’t checked?

If so, that seems unintuitive. If it’s not checked, why would it capitalize words after a closing quote (or at any time)?

If they were capitalized because it WAS checked, that also makes no sense. I have it checked, and no problem.


Because it would auto cap “Asked” because it was preceded by punctuation.

In what situation? The option was checked? Or it wasn’t checked? It doesn’t make sense either way. I have it checked, and that doesn’t happen.

It was checked - thus auto capping first letters of sentences - seems to make sense.

No, it doesn’t makes sense, because “asked Joe” is not a sentence … but I now realize it IS happening at my machine. I could swear it never happened before, but it does today.

Old behavior or new, I don’t like it. Unchecking the box may be worse than leaving it checked.

I’ve just tested this (Big Sur 11.2.1, Scrivener 3.2.2, MacBook Air 2020, British English), and it works fine for me - ‘asked’ is always (correctly) uncapitalised after ?" and I can’t find a way of getting it to misbehave…

I do have ‘Fix Capitalisation’ (in Scrivener) and ‘Capitalise Words’ (System Preferences) both ticked, but it’s rightly not being triggered after ?" – whether I use smart quotes or not.

Have you tried it in TextEdit, which uses the same engine? If it misbehaves there, then it’s likely to be a problem with you overall settings, not with those in Scrivener.

Update: TextEdit gets it wrong for me, too — you have to turn off “Edit > Substitutions > Text Replacement” to get it to behave. But this setting doesn’t affect Scrivener, which continues to work properly either way. This suggests it’s a problem at Apple’s level.

This combination of settings works as expected in Scrivener:

[attachment=0]Screenshot 2021-02-19 at 10.28.43.png[/attachment]

It’s a bug, then … probably related to Big Sur or the m1 silicon chip. I haven’t done a lot of writing since upgrading to both, so I didn’t run into this before. I thought I’d lost my mind for a bit. If you’re on Big Sur, the problem must be the m1 chip somehow.

So it’s because you had the checkmark in system preferences.

While “asked jon” isn’t a sentence per se, the system read it as the beginning of a sentence after a punctuation mark - in this case a question-mark. Uncheck that box in system preferences and it will stop the behavior in Scrivener.

That also means you have to watch your leading words in sentences, but I always hated auto-capitalize anyway. I’m probably showing my age in how I prefer to actually use the keyboard and the buttons to do my typing instead of allowing the system to guess and suggest words.

Does this make sense?

Yes, that’s exactly what I did. Also hate auto cap anyway.