Autocorrect capitalization error.

This may seem a little thing, but it’s subtle enough to make it through edit passes to submission desks (I actually noticed it only after hearing an editor complaining about the error in submission manuscripts).

Basically, it is automatically capitalizing the word after a ! or ? in quotes, even when it is the dialogue tag. It is very adamant about the correction to the point that I ended up sticking a comment on it when I got tired of fighting the change.

Reproduction steps:

Type a line of dialogue:
“George, get the car!” he said.

The “He” should be lowercase because the ! is not end punctuation but rather internal punctuation. This will not always be the case, but automatically correcting it will create many errors when writers are more likely to remember to capitalize the first word of a new sentence.

Thanks :slight_smile:.

I’ve just noticed this too and it’s driving me nuts. Is this an iOS setting or a Scrivener bug that will be fixed?

Have you tried after disabling the setting for Auto-Capitalization at Settings app > Scrivener > Spelling & Substitutions ?

I haven’t, but then auto-capitalization is fine in most circumstances. The logic needs to recognize this isn’t a correct capitalization. Since it only happens on iPad, the logic must exist (or I have auto-capitalization off on my desktop…

I don’t know if a developer has control at that level of code for the feature. My post’s purpose was for possible troubleshooting usage (didn’t know if you’d already disabled it) and to let users know that the feature can be disabled. It does come at the cost of more manual entries. Since Auto-Capitalization seemed to be causing you a great deal of trouble, I thought you might find disabling it (if you hadn’t already) worth that cost.

Good Luck.

Possibly not. I don’t program iOS, so offering a workaround is useful, thanks. However, it is still a bug and a programmer should address it whether to say it’s not possible because of iOS limitations or that it is being researched.

For me, it’s annoying but not critical. For the people submitting manuscripts that didn’t catch the error, it becomes more pressing, which is why I reported it because not everyone realizes it is an error.

This is really annoying me too. Has anyone found a solution, or is it just a case of globally turning it off?

For me, given I have a keyboard attached, I was able to turn off capitals for Hardware Keyboard. Still not ideal :confused:

Has anyone managed to find a fix for this? Do we know if one is planned. This isn’t a quirk, in my opinion, it’s a serious flaw that prevents me from using Scrivener on iOS as a serious writing tool. Any piece of software meant for writing prose needs to understand that it can’t auto-capitalize the first letter after a question mark followed by close-quotes.

As far as I can tell, this isn’t a Scrivener problem. This is an iOS problem. The same exact thing happens in Ulysses, and I just checked and it happens in Apple’s own Notes app too! It’s incredibly annoying and the only solution is to go into Settings -> General -> Hardware Keyboard and turn off auto-capitalization.

It’s not a big deal because I always capitalize the starts of sentences myself using the shift key when using an actual keyboard. But the operating system should totally be smarter than that. I hope they fix it in iOS 13?

I’m in iOS 13 beta and it still happens. Drives me nuts!

This is actually MUCH WORSE under iOS 13.

First, there seems to be no way to turn auto-capitalization off, as this option no longer appears in the settings app.
Second, it’s not just capitalizing after the other punctuation marks as before. When using a keyboard it’s now capitalizing after an apostrophe. And it capitalizes the next word, as well. So if you type something like the “it’s now” in the sentence above, what you get is “It’S Now.” Backing up and retyping will cause it to correct … sometimes. Often I find myself having to fight with the thing, even having to copy and paste in a lowercase letter, to get it to stick.

And under settings>Scrivener>Spelling & Substitutions the only option now is auto-completion, so there seems to be no way to address it.

I’ve tested this issue in other apps, and it is only happening in Scrivener. This is very nearly a “can’t use the app” issue, making it impossible to work without constantly fighting the editor.

Scrivener iOS does not support use under iOS 13 beta at this time, so I wouldn’t expect any action on issues pertaining to use with 13 until it’s at Gold Master.

Any update on this? Super annoying and slows down the process.

Thanks in advance!