Autocorrect dashes

Call me weird, but I want double-hyphens being autocorrected to en-dashes, and triple-hyphens to em-dashes (that’s how it’s working in LaTeX where I got used to it writing my theses, and for British or German I need en-dashes). I have this set-up in the system text settings. Scrivener 2 only has the option for correcting double-hyphens to em-dashes. Nevertheless, it worked fine (autocorrect defined in system text, Scrivener set to autocorrect to em-dashes. Would make en-dashes with two, em-dashes with three).

Until this morning, when Scrivener defaulted to em-dashes for double-hyphens. I do not know what has happened. If I turn off the Scrivener setting, it doesn’t autocorrect dashes at all. The option for getting en-dashes is gone.

How do I get it back?

1 Like

AAHHHH, ghosts!

It’s working again. I didn’t do anything! I just switched here to the forum, went back to Scrivener, and now it’s working again.

WTF? Can someone explain that?

1 Like

I had a similar thing happen yesterday, where Scrivener stopped auto-correcting quotes to smart quotes, as well as double-hyphens to em-dashes, despite the fact that all my settings were unchanged and definitely set to make those changes. I ended up following these steps:

  1. Uncheck all the “Substitutions” options in Scrivener Preferences/Corrections
  2. Quit the preferences pane
  3. Re-open it
  4. Re-check the boxes
  5. Restart Scrivener

It was one of a couple solutions I found on this thread:

I’ve seen this bug since the advent of Sierra. (There’s also a drag-and-drop issue that crops up also.)

The easiest solution I’ve found is to close Scrivener, restart Mac OS, and when you restart Scrivener everything works normally. This isn’t a bug I’d expect Keith to fix any time soon. It seems to be Sierra-related, and will hopefully be a nonissue in Scriv3.0

Thanks. It seems I didn’t do anything, but I guess I went through the preference panes of both Scrivener and system, and re-checked everything that did the trick.

So far, it seems to be a minor annoyance, given that I have written for months without anything like this to happen (at first I thought it was because I didn’t do en-dashes, but by the other reports it happens with other autocorrect options as well. Seems I was just lucky). We’ll see how it works in Scrivener 3.

I know this is an old thread, but I’m having the same problem. Scrivener suddenly stopped auto-formatting em dashes and smart quotes this week, despite me making no changes on my end (didn’t change any settings, I’m working on the same existing projects, etc.).

I tried unchecking and rechecking the Substitutions boxes and restarted both Scrivener and my computer multiple times, but nothing has worked. Is there anything else you guys tried that might be helpful? I’m using Scrivener 2.8.1 on El Capitan.


Okay, I’m getting this, too. It’s so annoying I’d like to roll back version 3.0 to my old, reliable 2.whatever.

I’ve tried turning off the smart quotes options everyplace, shutting down Scrivener, re-starting my Mac (OS Sierra 10.12.6).

Anybody come up with any new ideas on the whole smart quotes nightmare? HOW DO I TURN OFF SMART QUOTES OMG IT’S AWFUL.

ETA: Okay, I have found & staked every darn instance of this darn smart quote vampire now. I am victorious. (Could be simpler to turn this darn thing off, though, if you ask me.)

Re: smart quotes in S3: Turn it off in System Preferences, Keyboard, in the Text pane. Also turn it off in Scrivener preferences, in the Corrections pane. Also turn it off in the Scrivener Edit menu: Edit > Substitutions > Smart Quotes. You may have to turn it off in the edit menu for every single project.

Like a freaking vampire, it has coffins everywhere, but that should stake it through the heart.

I can’t find a way to hit ‘LOVE’ on your post, but your post nails it. No pun intended. ;p

You’re welcome!

As I understand it, in S3 it works like this:

the System Preferences aren’t supposed to affect smart quotes internal to Scriv, but sometimes they do. It’s just safer if you want them off, to turn them off here. If you hate Smart Quotes in Scriv, you’re probably not going to like them in Word, TextEdit, or Notes either.

the Scrivener Preferences affect whether the smart quotes menu item is toggled on when you create a new project. But of course if you just switched over to S3 from S2, the Scriv prefs are going to toggle that menu item on for every project you import if you don’t change it.

Finally, independent of Scrivener Preferences, you can turn smart quotes on or off on a project-by-project basis with the Edit Menu item.Which is something you couldn’t do in S2–smart quotes were either on or they were off, period, and controlled in Scrivener Prefs. So OK, if you’re doing a novel and you’re doing a thesis, you can have smart quotes off in the novel and on in the thesis, if you’re so inclined. This increased flexibility may be of benefit to many, but as you say, it’s darned hard to turn them off everywhere now. Or on everywhere, for that matter, if you change your mind. :neutral_face:

Yep - four years late, and a dollar short, but I’m having the same problem. I had my Mac set up to replace two hyphens with an en-dash, which worked a treat in Scrivener… until today when it didn’t. Suddenly it started replacing my two hyphens with em-dashes <shakes fist!>… until I turn off ‘Substitutions → Smart Dashes & Ellipses’ and now it replaces them with nothing. This is a problem - i.e. I can’t write this way! Typography nerds unite. L&L, please help! (Thanks!)

As a workaround you could also enter them directly:

- → – (n-dash)
- → — (m-dash)

. → … (ellipsis)

1 Like

I use TextExpander to simply this and many other things, with occasional help from Keyboard Maestro.

1 Like

My solution: Turn off smart dashes. Let the hyphens, in pairs or triples, be. Then in Compile, set up a compile time substitution of the en-dash for 2 hyphens and the em-dash for 3 hyphens. (Put the em-dashes first in the list, tho.)

Yes, it looks weird as you’re typing, but the output is what you want. After a while, I got used to it. No need for 3rd party utilities.

1 Like

That works for the limited purpose, but some 3rd parties (Karabiner, Keyboard Maestro, and TextExpander for me) can save a lot of time and trouble.

I’m glad they work for you. They don’t do it for everyone.

I bought Keyboard Maestro, and I have Better Touch Tool as part of my Setapp subscription.

I’ve used KM once. I uninstalled it and BTT. Too much bother.

Ellipsis is Opt-; not Opt-.



Nope. . → … vs. ; → ∞
For me. But this may vary depending on your keyboard / language.

UK English keyboard, here.

Ellipsis is also opt-; on my US English keyboard. But I agree that non-English keyboards may well differ.