Autocorrect is turning dont into dint. How to fix?

Hi. When I type the word dont it is autocorrected to dint. This is the only word that my ScrivWin does this to, and I’ve tried various ways of solving the problem… but it persists.
Here are my settings.
On the Options>Corrections screen, I have ticked ‘Correct spelling errors as you type’ and ‘Enable additional substitutions’.
When I ‘View Personal Word List’, I have added the word don’t with the apostrophe. The word dint is not there. There is no other relevant term there. The word won’t is there and that autocorrection works perfectly, that is, I type wont and it autocorrects to won’t.
On the ‘Edit Substitutions’ screen, there is nothing relevant.
So…I’m stumped. Can anyone assist?

Not a very wise auto-correct obviously, but ‘dint’ is a word and that is how it can be showing up as an auto-correct without being specially added.

Sorry, I know that is not a help.


Disable “Correct spelling errors as you type”, then type “dont” in the editor and right-click. Choose “don’t” from the spelling suggestions. That will give it precedence over “dint”. You should then be able to reenable the “Correct spelling” option and have it autocorrect to “don’t”.

That’s one reason I tend to be skeptical about “artificial intelligence” … !

We are frequently required to tell the computer what it doesn’t already know. :confused:


Also, importantly, you shared the principle of why this works.


A related issue:

I know the word “cant” is a real word but most times I mean “can’t” (cannot). How do I tell the spelling list that this is my #1 priority version of the word?

You can’t or is that you cant.


Is there no way to set “can’t” as the priority autocorrect rendering for the letters c a n t ?

Dont no ov n e spell chequer that can select based on user preference.

In OS X, you can set up a system-wide autocorrect. Not possible in Windows?

Or using the dont/dint/don’t fix above, can you fudge an autocorrect by changing cantt (or something else that is easy to type) to can’t?

Is it possible to edit/hack the list of words in the main dictionary…removing cant?

Briar Kit,

1, To set up a system wide autocorrect, I highlight the word and then right click to open up a list of options. Unfortunately spelling is not one of them.

If there’s another way to correct the spelling list, I have yet to find it.

  1. And I dont yet know how to edit the main spelling master list.

Thanks for your suggestions.

You can set up a substitution to replace “cant” with “can’t” via the “Edit Substitutions” button at the bottom of to Corrections pane in Tools > Options. Be careful with this, though–you may want to add a space on the end to help avoid replacing the sequence “cant” within the middle of a word.

Alternatively you could look into a more sophisticated global tool like AutoHotKey or Breezy to handle corrections like these, which will let you define it as a “whole word” replacement and will work outside of Scrivener as well.

Thanks MM.

Jennifer, that WORKS for me.

I notice the autocorrection only kicks in when I type the next letter after the blank space.

This discussion would not be complete without someone pointing out this alt fix: the method of explicitly typing the apostrophes. Just saying.


MM, couldn’t you make a substitution that takes the spaces around “can’t” into account? This would avoid changing longer words that include “cant.”

Strange that it took so long for someone to say this. Just type the word correctly, and you don’t need to worry about it. Or, catch it when you read back through. I would assume editing still exists for most writers, right?

Interesting question, Sang.

MM, can a substitution begin with a blank space?

Jennifer, I’m back with a similar issue which isn’t resolved by the above method. Pity, really, because that worked for me earlier.

When “Correct spelling errors as you type” is enabled (ticked):
If I type “dont” in the middle of a sentence, it autocorrects to “Dont”

When “Correct spelling errors as you type” is disabled:
The word “dont” is autocorrected to “don’t”.

I’d be grateful for some more of your magic.

Scrivener shouldn’t be making any spelling corrections at all if that option is disabled, so that may be coming from your substitutions list, e.g. if you have a replacement set up to change “dont” to “don’t”. Check to see if “Enable additional substitutions” is ticked, and click the “Edit Substitutions…” button to see what you have listed there.

I’d also check what’s set up in the personal word list, as that affects the auto-corrections for spelling, and “Dont” may have been added by mistake. If both the substitutions and the spelling auto-corrections are enabled in this configuration, you’d end up with any instance of “dont” being corrected to “Dont” before the substitution kicked in, and once it’s “Dont” it no longer matches “dont”, so it wouldn’t replace.

If that isn’t what’s going on, then there’s probably another program running that’s catching and adjusting the text. Some text expander or global shortcut services have autocorrect options like this, so that’d be a place to look.

Suuuuper tardy response (sorry I missed this!), but yes, it can. You’d want to be sure to include the space at the beginning of the “with” text as well, so you don’t remove the space entirely. That is, you’d want to replace " dont" with " don’t" so you retain the space before the word.

Got it. That worked, Jennifer, thanks.

I noticed in the ‘Edit Substitutions’ list that I’d also added wont → won’t, so I followed your advice for that one too. Turns out it didn’t work because the word wont is not red underlined, so the spelling options don’t show when you type it. And it’s not in my Personal List.

So I simply re-added it to the ‘Edit Substitutions’ list and it’s autocorrecting again. Until there’s a problem, I’ll let sleeping dogs lie.

Again, thanks.