Automatic numbering of the scenes

Thank you for this program, really happy to work with it. However, I have a question.
How can I enable the automatic numbering of the scenes in the script format? When I use “Compile”, it would be desirable to have automatically set the scene number before each line in the format-element Scene Heading.
I couldn’t find this explanation in the Manual.


Thanks for the kind words! At the moment, the only way to do this is to use the auto-numbering tags - so you would need to put "<$n>. " at the start of each scene name, which will then get converted into numbers during Compile.

Obviously that looks a little ugly during the writing process, however, so in a future version I will be adding the ability to have scenes auto-numbered during Compile without needing to add the tag during the writing process. That feature is still a little way off, though, so for now using auto-numbering tags is the only way to do it.

Thanks and all the best,

Thank you very much for the ‘secret’ method. :slight_smile:
It is very helpful to me.
And if you make the next version with this function will be very great.
Best regards,

Unfortunately, does not work. Am I doing something wrong?

Screenshots: Scrivener and pdf

The case of the letter matters; there is no <$N> tag. Use a lower case ‘n’, as in: <$n>
It’s easier to get an auto-tag into your text by using the Edit->Insert->Auto Number menu, then copy and paste whichever tag your choice produces into other locations.

Thank you!

Did the automatic numbering of scenes feature ever get added?

Yes. In Script Settings (Format > Scriptwriting), under Paragraph > Options… you’ll see there is an option to add sequential numbering.

All the best,

Thanks for the excellent program. Really useful for various types of documents!
It would be great to have automatic scene numbering available. I don’t see the option though in the scriptwriting settings under paragraph. What am I doing wrong? I’ve version: - 15 Jun 2018 installed on a Windows computer.

It looks as though you are on Windows. This was something added only very recently to macOS, for Scrivener 3, so it should be coming with Windows version 3 when it is available.

All the best,

Thank you for your quick reply. And for adding the automatic scene numbering in the next Windows version!
Al the best,

I’d also like to compile some pages of a screenplay and include scene numbers. I’m working on a Mac, using OS X and my Scrivener says it’s up to date (version, but when I go to Format>Scriptwriting>Script Settings>Paragraph there is no ‘Options’ menu.
How can I number my scenes automatically?

You’ll need to upgrade to version 3, if your Mac is capable of it, if you are willing to pay the $25 upgrade fee, and aren’t on a deadline. Among other things, the Compile functionality has been completely redesigned, so there’s a learning curve that should be tackled when you aren’t under time pressure to get things out of Scrivener.

Hi Keith,

I’m using this feature and it works great except for one bug.

If I have a title page when I compile to PDF, it inserts a blank page with a number 1. Then on the next page, the first scene begins without a scene number. All the subsequent scene numbers are numbered as expected.

If I don’t compile the title page the first scene is numbered as expected.

Any suggestions?

I cannot reproduce this - could you please post a sample project showing the issue?

I’ve attached a small project that demonstrates the problem.

Thanks //B (122 KB)

Interestingly, for me your project is hanging Scrivener 3.1.1, but it all works fine (with expected results) in my internal beta of 3.1.2, so I’m hopeful that this is fixed for the next update anyway.

All the best,

Any ETA on 3.1.2?

I’m compiling a screenplay to PDF for first time with Scrivener and I found that Scene Numbering isn’t working as I expected.
I’ve checked the Against Both Margins and nothing shows on the PDF.
Screen Shot 2019-04-15 at 11.24.26.png
Screen Shot 2019-04-15 at 11.25.08.png
Am I doing something wrong?

(Scrivener 3.1.2 on Mac)

Hi Keith

I was wondering if you can help me with a concern on this point. I am currently using Scrivener 3.1.5 on my MacOS (version 10.15.1).

I found the Format > Scriptwriting - Paragraph > Options setting mentioned above. I have entered for options for “Sequential Numbering Against Both Margins” (see screenshot).

But when I compile to PDF, no numbering appears.

All the Scene Headings that should be numbered are tagged as ‘scene headings’, so I don’t know why it’s not working :frowning:

Any help would be greatly appreciated!