B37 BUG? "No style" is not applied correctly when applied to existing text.

If I use File | Options | Editing | Formatting to set the default format for new documents (“no style”), click Apply, and then use the editor to change the formatting (Select All, and then choose “No Style” from the drop down), only part of the default format is applied. Line Spacing I have to change separately. In the Formatting dialog, I set it to 1.1x, and using “No Style” on existing text sets it to “1.3x 0.0/3.0.”

I HAD all of those set to “No Style” anyway, but B37 changed them to the default formatting from some time ago. This was unexpected. Font changed, also. Not sure why. I had to reset every document.

When you go in to the settings and adjust the default text formatting, you pick the font, size, color, paragraph indent, tab stops, and paragraph spacing for new documents created from that point forward. “No style” is just a lack of any applied paragraph or character styles, and doesn’t necessarily tell Scrivener “format my text this way”.

For existing documents, select them in the binder (one at a time, or in bulk), and use the menu Documents->Convert->Text to Default Formatting.