Back up Error - "Could not create file" [Solved]

I’ve been using Scrivener for a few years, just today started to get an error when I close a Scrivener project - a message box pops up saying:

"Could not create file:

Could not create file at:

There are backups already in the directory as it had been working fine ever since I started using it. I tried creating a new directory nearby, other places, etc no luck. Still throws the error every time I close the program. Nothing’s changed as far as I can tell from yesterday when it was working fine.

Currently using Scrivener for Windows

Some additional information:
Still fails to create backups even with “compress automatic backups as zip files” unchecked.
Running Scrivener with admin privileges doesn’t help.
Storing the backups on different drives still fails.
Reinstalling Scrivener does not solve the issue.

Getting some inconsistent behaviour - new projects (and two of my least used projects) create backups just fine. It’s just my biggest and oldest projects that refuse to backup properly. Using the “File -> Backup” option also does not work.
Attempting to make a copy of the project via “Save As” also fails with the error “Could not save project. Scrivener does not allow saving to a project’s .scriv folder” regardless of where I save it.

This is probably not surprising, but the issue was caused by working out of a cloud folder (used to be dropbox, now pCloud). I stumbled onto this post detailing why you shouldn’t do that, moved the project onto my harddrive and redirected the backups onto the cloud drive and everything works.