Background colour and text color bug

I am not sure if this has been reported, but here it is:

  • In preferences if I choose black background with white text for Composition Mode, when I go to Composition Mode I only get a black background. The text is invisible. .I have to manually choose white color for text (mouse right click + Text color + show color+ white.
    However it works this way, it affects the text color in the main editor, changing it from black to white as well.( In Main editor I have light blue color for the background with black text).

Please verify.


Previously you have set black color on your text. Try removing any color(the white box with a red line inside) from your text and you will see your specified Options color.

You can also override the text color in Options->Appearance->Composition Mode->Colors->Text. Screenshot:

I’m having the same issue. If I change the color on the main editor, it takes a few times before the text color will change. So If I change it from the default, white background with black text to dark gray with white text, the text typically stays black until I have chosen white a few times. It shows the color in the settings correctly, but not the actual editor. I think you have to change it to something entirely different first, then back to the color you want? It should just change it to the color I want the first click and after hitting the Apply button.

Guys, read and try my post above carefully before writing further comments. You MUST remove any text color from your text to see the expected color specified in the Options.

Thank you both for the explanations. It’s working now as expected.