Backup Folder - File couldn't be opened

Hi, I’m new to Macs so maybe there’s something really easy that I’m not doing, but when I go to Preferences, Backup, and try to choose the Backup location I get an error that the “File couldn’t be opened.” Is there something I’m not doing correctly in the file open dialogue box? Is this a bug? What’s going on?

What’s showing as your Backup location?

Mine is
/Users/sam/Library/Application Support/Scrivener/Backups

I think that’s simply the default.
If I wanted to change that, I’d hit the CHOOSE button, which would take me out into the file system and let me pick a location.

Are you trying to ‘open backup folder’ without the location of that folder first being specified?

It’s not showing anything for the backup location currently.

When I hit the Choose button it takes me into the file system but then when I choose a folder and hit open is when I get the error The file couldn’t be opened.

And no, I’m not trying to Open the backup folder without it being specified first. That doesn’t do anything at all.

Are you able to open that folder location directly, via Finder?

It sounds like there might be a permissions problem with the folder you’re trying to use.


Yes, I am able to open the folder in Finder.

I didn’t do anything different when I created the folder so I don’t know how the permissions would be messed up. How do you change permissions on a Mac anyway?

Hmm. What happens if you create a new folder, rather than using an existing one?

You can see file permissions on the Mac with Finder’s File -> Get Info command. Look down at the bottom of the pane.


Same thing happens when I try to use an existing folder, create a new folder, and when I try to choose a folder on Scrivener startup (it prompts me to choose a folder.)

Oh, and what should the permissions be? I have read & write access, everyone has read only. Is Scrivener everyone?

Hmm. Those are the permissions I have as well, so that’s not it.

Just out of curiosity, where are you trying to put the backup folder?

Also, is Scrivener behaving correctly otherwise?


Are you using the Mac App Store version of Scrivener? Make sure you’ve gone to Scrivener > Authorize Folder Access… to allow Scrivener access to wherever you want to store the backups. Section 7.12 in the user manual goes into more detail about dealing with the MAS Sandboxing.

Thank you Jennifer! That solved the problem. I don’t know if I’m using the app store version or not. I think not.

The “Authorize Access” option only exists in the App Store version (since there’s no sandboxing otherwise, thus no need to authorise Scrivener), so it sounds like you did purchase through the App Store. It’s possible to run the regular version after having once run the MAS version, so maybe you’ve done that in the past and thus don’t remember dealing with sandboxing previously. Anyway, I’m glad it’s all sorted now!