basic formatting issue

hello all. When I attempt to import a .doc file from Libreoffice, written in standard paragraphs, does this instead.

With Ashe hurt, Normally they’d have found the nearest motel and tucked in
for the night, but.

something kept pricking up the hairs on the back of Floyd’s neck, and he drove
for about an hour

and a half, stopping in a small town in the truck stop suburb of a town just
beyond the city

so, please tell me a .doc file isn’t too confusing for this program. I don’t believe I have the constitution to type everything out again, so hopefully this is something I am simply overlooking. All I want is to bring the half novel, already in separate .doc chapters into Scrivener, and any help would be greatly appreciated.

I would try saving the file as RTF from LibreOffice, since .doc is not native to either of these programs. You’re using a language they both must rely upon converters for, and that can make things messy. Next, check for invisible characters in LibreOffice and make sure it has been typed in correctly. There may be some formatting settings in LibreOffice that are obscuring line breaks that Scrivener won’t obscure, for example.

It looks though like there are hard breaks coming in where the text just wrapped in LibreOffice? You could verify this by toggling on Format > Options > Show Invisibles. You should see either an arrow, bending down and left, or a pilcrow, like a backward P. If you see a single blue dot, click into the end of the line and backspace to delete it; if there is a line break, that should make it appear. (There’s a bug with the invisibles that if the line ends with space, indicated by the dot, following invisibles on the line don’t appear.)

If you see those, I’d check for them in LibreOffice also by displaying non-printing characters there. If you see them, you can use find/replace to remove them, then re-save and import to Scrivener again.

If you don’t see them in Scrivener, or in LibreOffice, you may want to try re-saving to RTF and importing that. Scrivener does import DOC files, usually quite well, but it needs to run through a converter to do so and possibly that’s not handling the LibreOffice-created DOC well. LO will have its own flavor of RTF too, but it may be a little cleaner and provide a better import.

I’d also check which converter is being used for DOC import. Go to Tools > Options… and in the Import/Export tab click “Import Converters…”. Select DOC from the drop-down on the left and then choose the converter from the menu on the right. “Scrivener” is almost always the best option when you don’t have Microsoft Office installed, so if it’s “Doc2Any”, try changing it and re-importing to see if you get better results.

Final thought, given the limitations of formatting on the forum, maybe you’re seeing something like a set right indent, rather than wrapping at the right edge of the editor? That might make the text look like it’s breaking oddly, but it’s a simple fix. The easiest way is to convert the entire document to the default formatting, also nice for standardising your fonts and indentation in the editor. To set your default formatting, go to the Editor tab of Tools > Options… and use the format bar and ruler to adjust the sample text. (The blue A button on the left of the format bar opens the font options.) Click OK to apply the changes and close the Options. Your new defaults will automatically apply to all new documents you create (in any project). To change existing documents to match, select them in the binder (Ctrl- or Shift-click to select multiple) and then choose Documents > Convert > Formatting to Default Text Style.

Alternatively, you can change the indentation for each document by showing the ruler in the editor (Format > Ruler), selecting the text, and then dragging the right-indent marker just off the right edge of the ruler. It should spring back into place adhering to the edge of the ruler, so if you adjust the width of the editor, it always stays with the edge, and the text always wraps to the editor.

EDIT: Yeah, what he said. :wink: