Beachball after update?

Is anyone else out there noticing excessive beachballs in Scrivener after the macOS 13.3.1(a) update?


I had a few earlier today before lunch. I rebooted my Mac after lunch, and it seems to be working better since I did.

1 Like

Sorry, should have stipulated… :slight_smile: I’ll edit the OP.

The beach balling is specifically in Scrivener (3.3.1-15584)


I’d suggest installing the Scrivener version 3.3.1 (15588) update.

But again, I’m running that version and macOS 13.3.1(a) and encountered the beach ball earlier today in a Scrivener project. That project has been fine in Scrivener version 3.3.1 (15588) for a few weeks using macOS 13.3.1.

But, I’ve had other items hang today since installing the macOS 13.3.1 (a) patch last night. Rebooting my Mac has improved that issue.

1 Like

I had the problem today (3 May 2023) with an earlier version of macOS. I have since attempted to resolve the issue by updating to macOS 13.3.1(a) and downloading and reinstalling Scrivener v3.3.1 (15588) to no avail. All previous projects and new test projects now stall out, even the tutorial—often after typing a single character. I am unable to use the program presently. Is there a fix?

As I noted above, I was able to resolve the issue on my Mac by powering down completely and then restarting. That cleared the hanging issues in Scrivener for me.

You might fully power down your Mac if you haven’t yet to see if that resolves the issue for you.

We’ve just had four or so tickets about this hit the help-desk queue, so other users with this new macOS patch are also encountering the behavior.

From what I see on this MacRumors post, this is the first time Apple is using their new Rapid Security Response tool widely after beta testing it.

It also looks like it’s being distributed on a rolling basis, so some users might not have that update yet.

1 Like

@RuthS OK, thanks! After reading your last message I completely powered down, left it for a few, and restarted. That seems to have solved it.

Thanks Much

Powering down and waiting a few minutes before restarting and running Scrivener was not helpful. The problem continued upon creating a new blank document.

It helped here, though only for a bit. It’s back, and it seems to get more pronounced the longer the program is open. Almost like a memory leak, but I can find no other evidence. And no indication as to whether it’s the app, the os, or the combination of the two.


Ah drat it. I was hoping the powering down would work on your Mac like it did on mine.

Since this is a brand-new issue being reported since this new macOS update, I’m trying to gather as many facts about the computers and projects affected to see if that will help the developers with diagnosing this.

If you go to Scrivener > Settings > General > Saving, what is the autosave interval currently set to? The default is two seconds of inactivity.

If you bump that up to 10 seconds, does the beach ball issue improve?

Also, about how many MB or GB is the project(s) that are lagging? And, is it/are they stored on your Mac’s hard drive? Or, are they stored in a cloud-syncing service? If you’re storing the project(s) to a cloud server, which are you using?

The more data we can collect on this, the better.

I have had this issue for a few days. Sometimes it would start after typing a single character. Impossible to work on project.

Last night I upgraded to MacOS 13.3.1. And confirmed I had latest Scrivener (3.3.1).
Shutting down the computer for a few minutes made no difference. I tried a few different lengths of time for the shutdowns. Still no difference.

So, I shut down the computer overnight (turned power off, fluffed its pillow, and tucked its sheets in).

This morning the problem appears to have resolved itself. (I’m hoping “appears to have” proves to be “has”.

(The autosave on my device is the default 2 sec…)

To clarify for those that need to know, that setting is NOT an autosave interval. It is a setting that will save every time Scrivener detects that amount of time of inactivity, i.e. no keyboarding. Active work without pause will defer any saves until there is detectable inactivity.

Some people appear to misunderstand that.

OOPS. Mea culpa. Thanks for clarifying. Would hate for someone to lose something because of what I wrote. Truly. Thanks.

Thank you for the update on what you’re experiencing. If the issue returns, I’d love to get some additional data on your project. Perhaps we’ll be able to find a trend…

I thought that setting could be an issue, so to try and eliminate it as a problem, I set the interval to 300; no joy.

The project is a new one. This may also be why I thought it might be related to the Apple update, though others seem to be stating that they saw this before the 13.3.1(a) update.

Checking Info shows the project file at only 1.5 MB.

As mentioned before, I thought it could be a memory leak somewhere, but monitoring Activity Monitor (Memory) showed no sign of growth, at least not enough for Scrivener + Project File to show any growth at the MB level (321.5 MB).

27" iMac 2020
System Memory 32 GB
Storage: 512 GB SSD (NVME)

And, just for reference, I also have a 14" MBP (M1Pro) 16/512, 13.3.1(a), and it IS NOT exhibiting this issue.

Thanks Much